Hi all, new to the forum but have been lurking trying to fix this for about a month and have not found any other post in the exact same situation.

In one month of ownership the roof has stopped moving via the switch about 4-5 times now.

Symptoms:
1) Can happen from open or closed
2) Every time, it will begin to open/close and then stops when the deck lid unlatches. The deck lid does not then go up, it just hangs on top of latches about an inch up from the car.
3) The roof orange light on dash flashes throughout this, even after letting go of the switch once it has 'jammed'. NO warning messages are on (e.g. check trunk shelf).
4) Maybe unrelated, but it seems to have strong correlation with hot weather. Has only have done this on very hot days 75F+.
5) The following parts were all replaced by Audi according to the service paperwork I have, in 2018 - Top pump solenoids, N22 convertible top locking motor, F201 compartment cover open position switch, F293 convertible top compartment latch switch, Convertible top motor pump.
6) I have found this guide (and the link within it) but it didn't quite seem to correlate with the problem I'm having, though I am planning to have a go at it this weekend potentially.
7) To fix, I either have to manually lock/unlock the roof and use the T-key, or a couple of times if I just lift the deck lid up all the way it then carries on working again.
8) I have manually closed, open, closed the roof to reset the system and switches and it has since failed twice after that.

I have found this guide to renew the motor (point 6 above) but given that it was replaced recently (if the motor is part of the "convertible top motor pump", or is it just the pump excluding motor?) and seems to be deck-lid related more than motor itself it makes me think it's a sensor or switch related to deck.

Anyone got any ideas?