Audizine - An Automotive Enthusiast Community

Results 1 to 3 of 3
  1. #1
    Active Member Two Rings
    Join Date
    Dec 28 2017
    AZ Member #
    411678
    Location
    Poland

    MMI 2G High - white screen

    Guest-only advertisement. Register or Log In now!
    Hello,

    That is how my Audi said 'Hello' to me today :(

    The radio works (at least sound)...

    Is it a screen that should be replaced or fixed?

    Wysłane z mojego SM-G950F przy użyciu Tapatalka

  2. #2
    Stage 3 Forum Advertiser Four Rings Christian@enfig's Avatar
    Join Date
    Jul 12 2004
    AZ Member #
    2759
    My Garage
    2013 CC Executive Edition VR6 3.6, 2003 GLI VR6, 2005 A4 cab 3.0 V6, 01 GTI VR6. Past 89 & 78 Golf
    Location
    Fort Lee, NJ

    I have never seen that before. I would probably look for a used on on ebay.
    EnfigCarStereo.com - iPod iPhone & Aux Specialists - Radio Replacement Specialists
    info@enfig.com
    201-490-5015
    FaceBook

  3. #3
    Active Member Two Rings
    Join Date
    Dec 28 2017
    AZ Member #
    411678
    Location
    Poland

    Now it looks like that...

    Wysłane z mojego SM-G950F przy użyciu Tapatalka



Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


    © 2001-2019 Audizine, Audizine.com, and Driverzines.com
    Audizine is an independently owned and operated automotive enthusiast community and news website.
    Audi and the Audi logo(s) are copyright/trademark Audi AG. Audizine is not endorsed by or affiliated with Audi AG.