Audizine - An Automotive Enthusiast Community

Results 1 to 3 of 3
  1. #1
    Registered Member One Ring
    Join Date
    Dec 02 2018
    AZ Member #
    tulsa, oklahoma

    HELP A GIRL OUT!!! Transmission or Electrical???

    Guest-only advertisement. Register or Log In now!
    2013 A4 Quattro AWD Automatic with sport... Just bought this 2 weeks ago. Came from out of state. Seller said drove perfectly without any issues. So something happened in 3 days of transporting to me I guess. Can't send it back, already tried. When the car got here, drove it about 1/4 of mile to bring it home. Heard some grinding metal from the rear and felt like dragging. It was late at night so waited til next morning to check it out. Started fine next morning, let it warm up and then drove it through my neighborhood to listen and feel for things. Grinding still there, gear shifting fine, didn't mess with sport mode at all. Drove it for maybe 3-5 mins trying to figure out what the noise was and how it was handling. Parked it in drive and sat to listen to engine run. It started revving really high on it's own. Only way I could stop the revving was to put my foot on brake. But as soon as I let brake off, it revved right back up to about 4000. Shut it off, started it back up, same thing. Left it alone til that evening. Was going to take it to shop where my friend works, so get in, starts fine, let it warm up, reverse fine out of drive, get into street and when I put it in drive the Emergency brake comes on and locks. Finally figure that out but then drive doesn't work. Engine just revved. Mechanic friend comes over and gets it into sport mode and drives it to his shop. Hooked up to his VAGCOM. Showed all kinds of codes. Reset all the codes and then just had brake codes. Changed brakes and rotors that night. Next morning he tries to drive it out of shop and it won't go anywhere again. Reverse had also failed. Different lights would go off and on in dash at different times. Tow it to the Audi dealer who calls and says "New trans, $14K". HA!!! yea no...So tow it to transmission guy I know. Looks at it and says not transmission but electrical issue. And at that time the car would no longer communicate with scans. WTH??
    Towed the car home and have been working on it past few days. No I don't have VAGCOM and yes I know I will have to have some things reset but I am trying myself first because I don't have the finances to just let whoever replace whatever when no one even knows what's wrong. I have found out that this car was flooded as far as up to the steering column. Yes I know how bad this is and am beyond mad and frustrated but it is what it is and I need some serious help now. It was flooded in January this year and then has been driven from March until I got it. Mileage substantial enough to show it's been driven quite a bit previous to me and after salvage. All of that is beside the point because as I said, previous owner won't do take it back and return money. So I have a $10K car that runs like a jewel, but won't drive!!
    Here's what I've done so far: First I pulled up passenger side floor thinking I'd find the TCM. Nope, it's inside trans case. I can't get to that. I don't have a lift. Next I started hunting the ECU. Finally found that guy. Outside case looked fine. Opened it up, looks amazing like new. No corrosion or anything. Tested relays under it and all good. I've tried TCM resets like having the car on but not started, gas pedal to floor for timeframe and move gear from park to drive back to park... all those combos I found in these forums, I've tried them all. I disconnected the battery and tried to reset that way. Heard everything clicking and talking to itself when I hooked it back up. But it still won't drive. The car has moved a few times for me but only inches at a time. Today I put it in drive and it started to move ever so slightly but only when I revved up to about 3000. And when I put it in reverse, it went forward the same way. I get the "limited transmission functionality" in the dash when I put it in drive. And it tells me I have no reverse (NO @#it!! thanks dash lights, like I don't know this). So that's it. It's sitting in my garage. It's a gorgeous little foreign computerized POS!!!
    Any advice or thoughts or troubleshooting is much appreciated!

  2. #2
    Active Member One Ring
    Join Date
    Aug 22 2018
    AZ Member #
    North Europe

    Itís most definitely hundred percent electric problem. Problems with wires or trans ecu or ecu. Like your guy said, problem is it canít communicate with one another thru Can and it doesnít know what to do. Iím sorry I canít help more, Iím a spanner guy, you need an electrician.

    Sent from my iPhone using Tapatalk

  3. #3
    Registered Member One Ring
    Join Date
    Jan 20 2019
    AZ Member #

    This is why I'd never buy a salvage car. Sorry to hear you got swindled.

    Sent from my iPhone using Audizine


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

    © 2001-2019 Audizine,, and
    Audizine is an independently owned and operated automotive enthusiast community and news website.
    Audi and the Audi logo(s) are copyright/trademark Audi AG. Audizine is not endorsed by or affiliated with Audi AG.