Audizine - An Automotive Enthusiast Community

Results 1 to 6 of 6
  1. #1
    Active Member One Ring
    Join Date
    Oct 24 2018
    AZ Member #
    429646
    Location
    New Hampshire

    no CEL but still throwing code

    Guest-only advertisement. Register or Log In now!
    so I have a code p0340 Camshaft Position Sensor A Circuit Bank 1 or Single Sensor and I replaced the camshaft sensor and it did nothing. so I then replaced the speed sensor (crankshaft sensor) and my CEL went off but it still throws the code???? why could this be? I was thinking the timing belt but shouldn't the CEL still be on if that was the case?

    (fyi my first thought was dash light burnt out but I turned the car off and started it back up and it showed up when it went thru the system check then went out when system check was completed)

    any help would be greatly appreciated.....

  2. #2
    Veteran Member Three Rings SteelyS6's Avatar
    Join Date
    Oct 29 2011
    AZ Member #
    83182
    My Garage
    2004 Atlas Allroad 6MT, 2001 Kermit stage 3
    Location
    Winnipeg Manitoba

    Which engine? The 4.2's can have issues with the cam chain tensioner's.

  3. #3
    Active Member One Ring
    Join Date
    Oct 24 2018
    AZ Member #
    429646
    Location
    New Hampshire

    it's the 2.7t

  4. #4
    Veteran Member Four Rings rollerton's Avatar
    Join Date
    Sep 16 2010
    AZ Member #
    64156
    Location
    Central Wash

    unplug the sensor and drive. If the code is:--- 16724/P0340 - Camshaft Position Sensor (G40): Malfunction --Then it should change to something like 'open circuit/ short to plus' or something with it unplugged. Swap the sensors from each bank and see if the error follows the sensor to the other bank.
    If it does, bad sensor. If it doesn't ...not sure. Bad wiring?
    foley803 : What does an electrical surge sound like? Barking dogs? Watermelons?

  5. #5
    Veteran Member Four Rings PaperToast's Avatar
    Join Date
    Apr 29 2009
    AZ Member #
    41811
    My Garage
    Quadzilla
    Location
    Longmont, CO

    would a bad ground make funny things happen?
    if so . . .
    Rockin' the Rockies
    '01 allroad, 240k woot woot, still boosting on original turbos and tippy, slightly more modified. . .

    Scotty@Advanced, "Push it off a cliff, when it hits the ground you should have a few thousand horsepower available for a brief second."

  6. #6
    Active Member One Ring
    Join Date
    Oct 24 2018
    AZ Member #
    429646
    Location
    New Hampshire

    yeah but a bad ground would make funny things happen intermittently not do funny things and stay that way



Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


    © 2001-2018 Audizine, Audizine.com, and Driverzines.com
    Audizine is an independently owned and operated automotive enthusiast community and news website.
    Audi and the Audi logo(s) are copyright/trademark Audi AG. Audizine is not endorsed by or affiliated with Audi AG.