Audizine - An Automotive Enthusiast Community

Results 1 to 12 of 12
  1. #1
    Active Member Two Rings Justadam's Avatar
    Join Date
    Feb 26 2017
    AZ Member #
    394216
    Location
    Atlanta

    2014 S5 smelling coolant

    Guest-only advertisement. Register or Log In now!
    So 2014 with 70k miles, I smell coolant after stop and go traffic. Nothing super strong, but I can smell it when I exit the car and pass by the hood. I do not get any high temps, and the fluid looks the same with no loss, but the smell is there.

    It's still under warranty, but I'm sure they will never find anything, but has anyone else experienced anything similar?

  2. #2
    Established Member Two Rings Hey_T_S5's Avatar
    Join Date
    Nov 25 2017
    AZ Member #
    410309
    Location
    Allen, TX

    Not with my Audi but with other cars....stay vigilant as this could mean a worn hose, a pinhole in the radiator or a bad reservoir.


    Sent from my iPhone using Audizine

  3. #3
    Senior Member Two Rings bakedcorn's Avatar
    Join Date
    Jul 27 2015
    AZ Member #
    345284
    My Garage
    2016 White A3 Teknic S-Line with 19's
    Location
    Richmond Hill, Ontario

    We have this smell since day one of ownership on both the A3 and S3. Iíve reported on this odour and they simply state no leaks or anything and the levels are fine. Over in the A3/S3 8V forum plenty of owners complaining of the same odour. Some of had their water pumps replaced due to sweating or slow leak.


    Sent from my iPhone using Audizine
    His - 2015 Audi S3 Technik Florett Silver Metallic on 19's
    Hers - 2016 Audi A3 Technik S-Line Glacier White Metallic on 19's

    "I have nightmares that I'm going to wake up, and everyone's driving a Prius and living in a condo, and we're all getting health insurance".
    - Kid Rock

  4. #4
    Active Member Two Rings Justadam's Avatar
    Join Date
    Feb 26 2017
    AZ Member #
    394216
    Location
    Atlanta

    Well maybe I need to just spend the $85 for the deductible on the warranty for the dealer to find nothing but to document the complaint.

  5. #5
    Veteran Member Three Rings NuVega's Avatar
    Join Date
    Feb 06 2010
    AZ Member #
    54578
    Location
    Las Vegas, NV

    I believe I've read somewhere that there is a ventilation or small air gap in the reservoir tank cap lid that causes this, I get the same as well in my '14 S5.
    - 2014 S5 3.0T Prestige - : Plain ole S5 w/ a few cosmetic mods...

  6. #6
    Veteran Member Four Rings JamesRS5's Avatar
    Join Date
    Feb 27 2014
    AZ Member #
    149899
    Location
    Dubai

    You could try replacing the coolant cap and see if it cures the issue. They are a pressure relief cap and can fail.
    I accept a Stage II tuned S5 is quicker than an RS5
    Doug convinced me
    He's also the reason I don't come here much

  7. #7
    Active Member Two Rings Justadam's Avatar
    Join Date
    Feb 26 2017
    AZ Member #
    394216
    Location
    Atlanta

    Quote Originally Posted by NuVega View Post
    I believe I've read somewhere that there is a ventilation or small air gap in the reservoir tank cap lid that causes this, I get the same as well in my '14 S5.
    Really? I'm going to look into that. If you remember anything about this, please let me know.

  8. #8
    Veteran Member Four Rings namvar's Avatar
    Join Date
    Jul 10 2014
    AZ Member #
    263032
    My Garage
    2013, Q7 Prestige, Nissan 300ZX Twin Turbo, Cabinet full of Adam's Polish Products
    Location
    SF Bay Area

    Quote Originally Posted by Justadam View Post
    Well maybe I need to just spend the $85 for the deductible on the warranty for the dealer to find nothing but to document the complaint.
    deductible only applies if they find something and fix it. At least that's the way mine works. Remember that the dealer makes money whether you pay for the work or the warranty so it's to their benefit to find something

    2015 RS5: Mythos Black, Tech, Dynamic steering, Black Optics packages, Folding side mirror upgrade, internal LED lights, Eventuri Intake, Akrapovič exhaust
    On order: Bilstein B16 RideControl
    2013 3.0T Prestige Q7: Sport pedals, LED interior lights

  9. #9
    Veteran Member Four Rings bhvrdr's Avatar
    Join Date
    Jul 21 2004
    AZ Member #
    2873
    Location
    South Florida

    Quote Originally Posted by JamesRS5 View Post
    You could try replacing the coolant cap and see if it cures the issue. They are a pressure relief cap and can fail.
    Also check your PCV coolant lines and your intercooler cores. They both fail.

    Mike

    2010 Audi A4 Avant 6AT - Unitronic Tuned - Bone Stock Hardware
    13.665 at 97.71mph - 93 octane - +1250DA
    Gone:
    2013 Audi S5 DSG - Unitronic Stage 2++ ECU & TCU, 3.17pr, Revo Charge Cooler, CTS Turbo Intake, ST60 380mm BBK
    11.482 at 118.70mph - 97 octane - +465DA
    --------------------------
    2016 A6 -- 2015 S4 -- 2009 A4 -- 2004 S4 -- 2006 A4 -- 2003 A4 -- 2000 A4

  10. #10
    Veteran Member Three Rings NuVega's Avatar
    Join Date
    Feb 06 2010
    AZ Member #
    54578
    Location
    Las Vegas, NV

    So I grabbed this from another forum, the a5OC forum:

    "Coolant smell
    Took car to dealer. They checked the reservoir cap and found that it's release of pressure was occurring at too high a level - thus discharging out a small amount of coolant. Cap replaced. Things much better now."

    I might look into this too, replacing the cap.
    - 2014 S5 3.0T Prestige - : Plain ole S5 w/ a few cosmetic mods...

  11. #11
    Active Member Two Rings Justadam's Avatar
    Join Date
    Feb 26 2017
    AZ Member #
    394216
    Location
    Atlanta

    I think I'll buy a new cap before going to the dealer to check it out. When I looked up the part online, I just noticed that there was an O ring there too. It would make sense that the cap and ring has deteriorated some.

    Thanks everyone!

  12. #12
    Veteran Member Three Rings NuVega's Avatar
    Join Date
    Feb 06 2010
    AZ Member #
    54578
    Location
    Las Vegas, NV

    Just replaced my O-ring today, I noticed it looked pretty flat as compared to the new one I replaced it with. Going to see over the next few days if I notice anything.
    - 2014 S5 3.0T Prestige - : Plain ole S5 w/ a few cosmetic mods...



Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


    © 2001-2018 Audizine, Audizine.com, and Driverzines.com
    Audizine is an independently owned and operated automotive enthusiast community and news website.
    Audi and the Audi logo(s) are copyright/trademark Audi AG. Audizine is not endorsed by or affiliated with Audi AG.