Audizine - An Automotive Enthusiast Community

Results 1 to 17 of 17
  1. #1
    Established Member Two Rings
    Join Date
    Apr 06 2015
    AZ Member #
    325453
    Location
    los angeles

    recently installed clutch now have very hard pedal

    Guest-only advertisement. Register or Log In now!
    i recently installed south bends clutch and now i have very hard pedal like hiting a wall it dont move, i had to replace clutch master it blew out and now i replaced that now the hose popped out ima get new hose. are these clutch known too be VERY hard in very lost on how much pressure it needs

  2. #2
    Veteran Member Three Rings ruiz's Avatar
    Join Date
    Apr 07 2009
    AZ Member #
    40895
    Location
    Right there
    Items for Sale

    Nothin to see here
    Last edited by ruiz; 08-05-2018 at 11:17 AM.

  3. #3
    Veteran Member Four Rings zillarob's Avatar
    Join Date
    Nov 16 2010
    AZ Member #
    67118
    My Garage
    2kS4, 84gli, 84caddy dsl
    Location
    WetSide, WA
    Items for Sale

    What sb clutch? If not a sac pp, pedal should be very soft, sometimes too soft.
    Last edited by zillarob; 08-05-2018 at 12:16 PM.
    There are only 2 things needed to make an Audi work properly - Duct tape and WD40. If it moves and it shouldn't - Duct tape. If it doesn’t move and it should - WD40.

  4. #4
    Veteran Member Three Rings ruiz's Avatar
    Join Date
    Apr 07 2009
    AZ Member #
    40895
    Location
    Right there
    Items for Sale

    Ermm yeah you're right...I confused with it a hard brake pedal haha good catch

  5. #5
    Veteran Member Three Rings
    Join Date
    May 20 2012
    AZ Member #
    93814
    Location
    San Jose

    Sounds like the slave cylinder is misaligned. If the pedal is hard as a rock and the clutch pressure plate doesn't move, that's it.

  6. #6
    Veteran Member Four Rings zillarob's Avatar
    Join Date
    Nov 16 2010
    AZ Member #
    67118
    My Garage
    2kS4, 84gli, 84caddy dsl
    Location
    WetSide, WA
    Items for Sale

    Quote Originally Posted by oppositelock View Post
    Sounds like the slave cylinder is misaligned. If the pedal is hard as a rock and the clutch pressure plate doesn't move, that's it.
    Thats where my $$ would be too.
    There are only 2 things needed to make an Audi work properly - Duct tape and WD40. If it moves and it shouldn't - Duct tape. If it doesn’t move and it should - WD40.

  7. #7
    Established Member Two Rings
    Join Date
    Apr 06 2015
    AZ Member #
    325453
    Location
    los angeles

    thank you guys ima get new braided steel line for clutch then ill recheck the slave cyclinder. SB stage 3 endurance

  8. #8
    Veteran Member Four Rings zillarob's Avatar
    Join Date
    Nov 16 2010
    AZ Member #
    67118
    My Garage
    2kS4, 84gli, 84caddy dsl
    Location
    WetSide, WA
    Items for Sale

    What part of the hose popped out?
    If it popped out of the slave, you prob just need to put it in right, but might need a new slave (prob not).

    Stg3e is a sweet clutch. It will have a light pedal when done.
    There are only 2 things needed to make an Audi work properly - Duct tape and WD40. If it moves and it shouldn't - Duct tape. If it doesn’t move and it should - WD40.

  9. #9
    Established Member Two Rings
    Join Date
    Apr 06 2015
    AZ Member #
    325453
    Location
    los angeles

    i really hope, it poped out from slave master cyclinder and slave is new and now also master but only poped out
    the master the plasic peace broke that holds the c-clip im coming from CM FX350 its wanst holding at stage 2+ with WMI

  10. #10
    Established Member Four Rings JustManson's Avatar
    Join Date
    Oct 11 2016
    AZ Member #
    382924
    Location
    Connecticut

    I can hardly read this....

    From what I can make out the braided hose is NOT going to fix your issue.

    If the Slave plunger is misaligned you have to remove it and try to realign.

    Good luck!


    Sent from my iPhone using Audizine

  11. #11
    Established Member Two Rings Isaac313's Avatar
    Join Date
    Aug 15 2017
    AZ Member #
    405034
    My Garage
    2008 Ford F350 Diesel - 2000 Audi S4 - 1994 Ford F150 Lightning
    Location
    Michigan

    Whenever my slave was misaligned the slave would try to overextend itself and blow the end off the slave causing me to need a new one. I was getting so mad at it after many hours of changing them, acquiring new ones, and trying to bleed them. The ones from autozone are Luk brand from what I can tell, and made from metal. Much better quality than oem so far.

    Good luck, hopefully you're able to squeeze your hands down in there well enough to finish it up.

  12. #12
    Established Member Two Rings
    Join Date
    Apr 06 2015
    AZ Member #
    325453
    Location
    los angeles

    yeah i got the autozone both master and slave. now im waiting on hose. Isaac313 did your pedal get hard when you pluger popped out ?

  13. #13
    Established Member Two Rings Isaac313's Avatar
    Join Date
    Aug 15 2017
    AZ Member #
    405034
    My Garage
    2008 Ford F350 Diesel - 2000 Audi S4 - 1994 Ford F150 Lightning
    Location
    Michigan

    No, the pressure escaped out the end of the slave and the pedal went straight to the floor.

  14. #14
    Veteran Member Four Rings zillarob's Avatar
    Join Date
    Nov 16 2010
    AZ Member #
    67118
    My Garage
    2kS4, 84gli, 84caddy dsl
    Location
    WetSide, WA
    Items for Sale

    It gets rock hard right before it pops.
    There are only 2 things needed to make an Audi work properly - Duct tape and WD40. If it moves and it shouldn't - Duct tape. If it doesn’t move and it should - WD40.

  15. #15
    Senior Member Two Rings
    Join Date
    May 14 2012
    AZ Member #
    93545
    Location
    new jersey

    That's what she said zillarob

  16. #16
    Established Member Two Rings
    Join Date
    Apr 06 2015
    AZ Member #
    325453
    Location
    los angeles

    it was the plunger thank you all very much, helped out very very nice

  17. #17
    Veteran Member Three Rings
    Join Date
    May 20 2012
    AZ Member #
    93814
    Location
    San Jose




Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


    © 2001-2018 Audizine, Audizine.com, and Driverzines.com
    Audizine is an independently owned and operated automotive enthusiast community and news website.
    Audi and the Audi logo(s) are copyright/trademark Audi AG. Audizine is not endorsed by or affiliated with Audi AG.