Audizine - An Automotive Enthusiast Community

Results 1 to 4 of 4
  1. #1
    Established Member Two Rings
    Join Date
    Nov 24 2017
    AZ Member #
    410255
    Location
    Virginia

    Driver Information Display Black screen :(

    Guest-only advertisement. Register or Log In now!
    Model: 2012 S4 prestige line.

    Wtf, been driving the car 6 months now no issues. Rarely drive in the rain if ever, garage kept. Get im thid am and drivers display dead. Cluster still functions, fuse for cluster is good. Did an MMI reset just for fun to see if it affected. I get random dings from the cluster but no display from DID. Anyone have this issue. Not near my house at the moment to hook up the OBD eleven to check for fault codes.

    Sent from my VS995 using Tapatalk

  2. #2
    Established Member Two Rings
    Join Date
    Nov 24 2017
    AZ Member #
    410255
    Location
    Virginia

    Btw also hit reset on the stalk. No change in screen. What erks me is there was no issue before or sign if fatigue. Just black.

    Sent from my VS995 using Tapatalk

  3. #3
    Established Member Two Rings
    Join Date
    Nov 24 2017
    AZ Member #
    410255
    Location
    Virginia

    Scanned the car. Only fault codes are for open circuit on sub and tire pressure monitor. Attached diag on batt at rest after driving 15 minutes. Put my multi on the batt for load test holding at 12.35. Ill see if she has a draw by end of day. Varta battery manu 43/11, 2 years past her life expectancy but charge is good thus far.

    Sent from my VS995 using Tapatalk

  4. #4
    Established Member Two Rings
    Join Date
    Nov 24 2017
    AZ Member #
    410255
    Location
    Virginia

    And I fixed it. Found a thread on here in regards to replacing if screen fails. Two options both involve removing cluster.

    To remove and reseat screen

    Pull trim (carefully) left right and bottom
    Remove (3) bolts to cluster (8mm)
    Remove (5) torx bolts to cluster trim (t15)
    Flip cluster, Remove (4) torx to cluster cover (t15)
    Pull cover flip again remove (3) torx to DID (t8)

    Pop out and reseat, install (1) t8 to hold in place and test. If it works reassemble and reset time.

    If not, buy following replacement screen and do process over again. Below for search info on screen replacement.

    Audi A4 8K S4/RS4 and Audi A5/S5/RS5 Magneti Marelli instrument color display


    See attached for gen pics.





    Sent from my VS995 using Tapatalk
    Last edited by Phil Dammit; 06-17-2018 at 08:07 PM.



Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


    © 2001-2018 Audizine, Audizine.com, and Driverzines.com
    Audizine is an independently owned and operated automotive enthusiast community and news website.
    Audi and the Audi logo(s) are copyright/trademark Audi AG. Audizine is not endorsed by or affiliated with Audi AG.