PDA

View Full Version : EBC issues, help!



BranCKY3
09-15-2006, 08:21 PM
I'm running a Greddy Profec B Spec II EBC, I had some top end boost surging if you remember my lost thread from last week, but now that issue is gone. Now, I have some boost hesitation when I go WOT anywhere over 3k... it will hesitate at the wastegate spring level (~12psi) then go to 15, hesitate again, then go to 23 like it should. It holds perfectly fine once it boosts correctly, but it sucks cause boost won't build fast.

My EBC settings are as follows:
Set 74%
Gain 16%
Set Gain 186
Warning 260
Limit 4%

I tried changing settings but nothing would eliminate the problem. I'll be putting my MBC back on tomorrow to rule out a wastegate line problem, maybe the line from the compressor housing is kinked or something and causing this. Any other ideas?

BranCKY3
09-16-2006, 04:39 PM
Fixed, I'm an idiot haha. The boost line going to the EBC unit in the car was kinked.

Ray Khan
09-17-2006, 05:03 AM
great....so now how does she run? What are you boosting? Holding pretty solid? I saw the solenoid on the spec 2 and it's not even half as big as the one on my spec 1. Although mine just has a couple of knobs. I assume once you dial in the SPEC it works very well.

BranCKY3
09-17-2006, 08:42 AM
It runs great, very strong. I'm spiking around 23-24 psi and holding around 22 to redline. I got an updated chip last weekend, it feels a lot faster so I can't wait to get back to the track and see what I can run.

illbill
09-18-2006, 09:18 AM
sounds like you have one of the better B5 eliminator setups running. Nice CAPS time btw!

So now that you have your boost under control, what ebc settings did you end up sticking with?


Originally posted by BranCKY3
It runs great, very strong. I'm spiking around 23-24 psi and holding around 22 to redline. I got an updated chip last weekend, it feels a lot faster so I can't wait to get back to the track and see what I can run.

k0mpresd
09-18-2006, 09:29 AM
me and a friend installed a profec b spec 2 in a car a month or two ago

couldnt get more than ~14psi no matter what we did

pulled it back out of the dash..kinked hose going to the back of the controller...[headbang]

BranCKY3
09-18-2006, 09:31 AM
I'm still running the settings in the first post in this thread. It still needs a little work I think, since the boost falls off in the higher RPMs, unless that's a limit of the turbo

BranCKY3
09-18-2006, 09:33 AM
Originally posted by k0mpresd
me and a friend installed a profec b spec 2 in a car a month or two ago

couldnt get more than ~14psi no matter what we did

pulled it back out of the dash..kinked hose going to the back of the controller...[headbang]

I don't know why Greddy doesn't make the unit use a nylon boost line like boost gauges do. It would be much easier to run it and no worries about kinking.

bitterchild
09-18-2006, 09:44 AM
run sleeve on the line from the unit to through the firewall.

k0mpresd
09-18-2006, 09:55 AM
that would be too easy

illbill
09-18-2006, 09:55 AM
could be a wastegate thing. I tightened the rod a couple turns and it helped with the tapering a little bit.


Originally posted by BranCKY3
I'm still running the settings in the first post in this thread. It still needs a little work I think, since the boost falls off in the higher RPMs, unless that's a limit of the turbo