PDA

View Full Version : Save me from taking my car to the dealership!!



NogaroA4
03-22-2006, 07:23 PM
Ok I'm going to try to make this as short and sweet as possible. Ok I just got done putting a new dash harness in my car, so I know my wiriring is ok. I can't get air to blow out of my center air vents. When I vag com my car I come up with 3-4 codes under "Auto HVAC". I will type up the exact codes when i get home tomorow. But they pretty much have to deal with different motor flaps etc. And I know I have the right wires running to the right motors becuase They are color coded. If someone could give me a crash course on vag com for testing different motors using vag com that would be great.

My one big quection is which motor blows controls whether or not the air comes out of the center vent,

My next quection is a 99.5 climate control has the same connections as a 2000 climate control, but a different face plate due to the single din cd player. Is there different pin outs for the 99.5 vs the 2000 climate contorl?, or just a different face plate?


Here are the vag codes



Thursday,23,March,2006,09:50:57

VAG-COM Version: Release 512.1-UD



Control Module Part Number: 8D0 820 043 Q

Component and/or Version: A4 KLIMAAUTOMAT D56

Software Coding: 00140

Work Shop Code: WSC 06335

4 Faults Found:

00603 - Footwell/defroster Flap Positioning Motor (V85)

41-00 - Blocked or No Voltage

01272 - Positioning Motor for Central Flap (V70)

41-00 - Blocked or No Voltage

01274 - Air Flow Flap Positioning Motor (V71)

41-00 - Blocked or No Voltage

00792 - A/C Pressure Switch (F129)

31-00 - Open or Short to Ground

jones3000
03-22-2006, 08:36 PM
good luck man.

bitterchild
03-22-2006, 10:24 PM
audi likes to change pinouts and connectors w/ revisions in general. sorry, that's all i can contribute

NogaroA4
03-23-2006, 04:35 AM
Originally posted by bitterchild
audi likes to change pinouts and connectors w/ revisions in general. sorry, that's all i can contribute


ok thanks...I guess my only option left is to try to get my hands on a cheap 99.5 control box, and see if that fixes it

A4euro
03-23-2006, 06:08 AM
hey Nogaro, still have your dash apart? I finished my heater core swap the other week and it wasn't that bad. Although after completing everything the wipers didn't work. So I had to take the steering column apart again and found the wiring clip was in, but hadn't clicked in fully. Just check and make sure that they are all clicked/locked in. Other than that, that's all I've got for you. Sorry I couldn't help more. Good luck.

NogaroA4
03-23-2006, 06:32 AM
Thanks...yeah I have all my dash just about all together. I'm just tryign to figure out this climate control thing..


The only thing that I can think of is that the units found in the 2000 + a4s have the same conectors but different pin outs becuase of the new engine, and since you can tell your rpm, oil temp etc from your climate control im thinking that they have different pin outs becuase of it.

TomRitt18944
03-23-2006, 07:41 AM
Hey Ryan, if u want u can plug my climate control in next time I'm home and we can see if that makes it work, then you will know whether or not thats what u need to buy

NogaroA4
03-23-2006, 08:39 AM
Hey sounds good Tom.

This weekend, I'm going to take out the bottom of the dash this weekend, and replace the motors that came up when I vag commed the car. Hopefully as weird as this may sound the three motors are just bad and thats all I have to do.

Its just weird cuz sometime they work and sometimes they dont. I know its not the conections I checked them all, but sometimes when i turn on the car the heat blows out of the center vent, and sometimes it blows out of the defroster, but I can't change them (like switch inbetween the vents).

TomRitt18944
03-23-2006, 09:12 AM
I'm coming home this weekend, although not with my car cause it ate another motor, but if you want I could bring my climate control home and there is a meet Sat if u wanna try it there

SeanF
03-23-2006, 09:45 AM
tomsapimp, always willin to help

NogaroA4
03-23-2006, 07:11 PM
tom i sent you a pm, thanks

Neo1130
03-23-2006, 07:18 PM
You can do an output test of the climate control panel through vagcom. It cycles through the different vent flaps so you can tell weather or not it is the motor or the unit. If you want to be original I have an Audi TT panel I will sell you for $50 shipped... Just have to make a custom bezel around the rest of it... I think it would look pretty damn sharp! Yes it works... I tried it in my car while troublshooting my A/C...

NogaroA4
03-23-2006, 07:24 PM
I did an output test throught vag com and the recir motor wasnt moving when I was doing it. I dont think its the motor becuae I dont know why that would of went bad, unless it shorted out when I had the old harness in that was spliced up. I am thinking that they changed a couple of the pin outs from 99.5 climate control and 2000 climate control, everything else seems to be working correctly excpet for the four motors that control the vents and temp.

NogaroA4
03-23-2006, 07:25 PM
Pretty much what it comes down to is I'm going to test Tom ritts climate control which is from a 99.5 on saturday.

If that doesnt move the motors then im going to say that its the motors that are bad and pull some of those from the junkyard and try those.

Neo1130
03-24-2006, 03:45 AM
Ah, same thing happened to me... I think you may find that it will be the control panel... If all FOUR of the servos don't move then I bet it is the control panel... Do you know if you can move the temp select vent or in other words, can you change your temp and feel it through the vents?

NogaroA4
03-24-2006, 04:28 AM
I have seen the temp select motor move. I dont have my ac charged, and never really got the car hot enough at idle to acutally test to see if the temperature changes when i increase or decrease it. But When I was going through vag com test I have seen it move to anwser your quection. thanks for all your input