PDA

View Full Version : Leaking Coolant



ProfileTrader
06-05-2019, 07:13 PM
Hi, need some help to determine where I am leaking coolant. When I drove today for a while after I pulled in the garage and turned off the engine I notice I was leaking coolant from the front (drivers side). It was dripping a lot from just behind/near the oil filter. First question.. Is there an overflow near there - if not I looked at the hoses and I do not see a leak (may need to wait till the car is cooled off (Arizona heat) as the car is too hot. Any ideas would be most appreciated. I leaked enough to go from Max to Min on the reservoir.

125037

Blazius
06-06-2019, 02:08 AM
Check the drain plug.

ProfileTrader
06-06-2019, 08:34 AM
Okay thank you - did not think of that - again much appreciated. I looked there and it looks like it may have come from there. It is screwed in okay - can they blow out and are they replaceable? It is not currently leaking - does it act as a relief valve.

125084

ProfileTrader
06-06-2019, 03:45 PM
Took off the bumper. Looked at the drain plug. - not the issue. Ran the car and I think it is the radiator. Tell me if you think that is correct or if I should consider something else. You can see the leaking (coolant) in the top picture as well as the bottom bushing. Also it is running along the bottom of the radiator.


125142

125141

Blazius
06-06-2019, 05:01 PM
Its possible , check the lower rad connection, its pushon kinda thing but the "Clamp" is like a pushdown before u can remove it ( dont if u have coolant in it ). Possible its not pushed up far enough, the gasket is leaking.

ProfileTrader
06-06-2019, 05:51 PM
I will - but on the side it leaking there is no lower hose unless you are referring to something different. The upper hose on that side appears okay. And then there is the coolant in the upper part of the radiator on the plastic in the top picture above. Will pull the front end back and look at it tomorrow and give an update. Thanks for the help.

ProfileTrader
06-07-2019, 06:28 PM
Update... I removed the condenser to get a better look. Did not put the car in service position since there is no hose at the bottom where the leak is (unless I am wrong). It appears it is the radiator. Tell me if I am incorrect. See below. Thank you.

125397

Blazius
06-08-2019, 03:21 AM
https://i.imgur.com/SN9bjOf.png

This is what I am talking about.

ProfileTrader
06-08-2019, 08:41 AM
My fault and apologies.. I did not post my car engine model. It does not have that lower hose. It is the AFC engine. It just has the top hose on the side it is leaking.. just pulled the radiator out to confirm. So it looks like a new radiator is needed.

Thanks for the help. BTW where did yo get that schematic of the radiator and hoses. If online could you give me a link to the website.

Blazius
06-08-2019, 09:41 AM
There are online diagrams etc, but I am using ETKA for everything.

yes the AFC is V6, and the rad is different :) but indeed it does look like the Radiator. Pull it off and fill it up with water and you'll find out.

ProfileTrader
06-08-2019, 11:32 AM
Thanks for the info and help.