PDA

View Full Version : CEL after carbon cleaning



goodforyou24
11-03-2017, 04:24 PM
Hey guys,

So I got a carbon cleaning (spray nozzle set at throttle body with a fuel additive) done on my s5 and it's been having issues since. At first everything was good, then randomly when I was driving the EPC light came on. So I pulled over and tried turning the car off and on again and the CEL popped up too. When I checked the codes it was for the throttle body, intake air control system reading high rpm, and random misfires. After driving for under a mile the EPC light popped off. I was far away from home and my mechanic said it'd be ok to drive back to town. I haven't felt a single misfire, the only thing that seems odd is the idle is sometimes at 600rpm instead of the usual 500. The light stays off for a bit, then randomly pops back on, normally after I start it while I'm letting it warm up. The outside temperature sensor also keeps reading stupid high, today it was 78 and the car is displaying 141. I also noticed that the throttle body appeared to have a loose bolt on the bottom, so I tried to tighten it and the threads are stripped off the inside, which was making me think that may be the issue.

I talked to my mechanic and he said I should bring it to Audi after driving it for another week to make sure all the cleaners are out of the engine if the light keeps popping on. Since the cleaning I've gone through 2 tanks of gas and driven over 650 miles. Before I go to Audi does anyone have any ideas, maybe the missing bolt on the throttle body it causing the issue? Thanks in advanced!

Hatchman
11-03-2017, 06:18 PM
The missing screw could be allowing unmetered air around the throttle body base. That could throw your inlet air out of specs and could be the result of some of your codes. Should be an easy fit, could try a bigger screw or if that doesn't work tap it out and insert a helicoil. You can get a helicoil kit on Amazon for 30 bucks.

goodforyou24
11-04-2017, 10:52 AM
Is there a throttle body blade adjustment screw that may need to be tightened to close the blade slightly since all the carbon possibly blocking the blade from closing was cleaned off? There is a little more room than I would have thought closing the blade by hand.

vladsly
11-24-2017, 01:11 PM
This sounds pretty similar to having a malfunctioning MAF (Mass Airflow Sensor). If you just unplug it, the car will default to a preset Air/Fuel ratio, and both EPC and Check engine lights will illuminate. I had the same problem when I had it unplugged, didn't plug it all the way back in and had higher than normal idle as well as both lights. Like Hatchman said, try getting a screw where it's stripped, unplug the MAF, plug it back in, and then restart the car. Hopefully this helps!

goodforyou24
12-12-2017, 09:43 PM
I had a throttle body alignment done first since it was easiest and I haven't had any issues since.

outback
12-14-2017, 08:36 PM
I had a throttle body alignment done first since it was easiest and I haven't had any issues since.

Great to hear, thanks for replying back to help the community.