PDA

View Full Version : Some clutch concerns



E Fresh
12-23-2005, 10:23 PM
I pm'ed a member of audizine about this. I also wanted to some of your guys feedback aswell.
This is what I wrote:


Hey J***,

Sorry to bug you. I saw your DIY on Clutch removal and replacement. I bought my car alittle while ago and the previous owner had an aftermarket clutch installed about 20K miles ago. Its a SPEC clutch(stage two I think he said). Anyways, I wanted to ask you some questions about the clutch. First, it makes a subtle noise when sitting at idle. It makes a lot of chatter. The noise goes away when I push the clutch in though. Second, I find my clutch really hard to drive. My car only pulls away smoothly when I rev it up to like 2K rpms, anything less then it is really shakey. I was wondering if you have any idea maybe what would be causing this? Is this normal for the SPEC brand clutch? I was reading, and I saw the part where you were talking about the step height of the flywheel requirements causing excess friction. Could this be what is wrong? I appreciate any feedback or suggestions you are willing to give. Thanks for taking the time to read my PM,

Jon

Any one know if this is something I should worry about? Is the clutch going bad or is this the way the SPEC clutch is supposed to be? It only has 20K miles on it. My main question and concern is the subtle noise. Is this something I should worry about. Do any of your guys after market clutches make some noise? Thanks in advance for anyones opinions or feedback,

Jon

kelticslob
12-23-2005, 11:35 PM
Aftermarket clutches are typically harder to drive than stock. I drove a friends Civic rice rocket with a very heavy clutch, and it gave me whiplash when I tried to take off slow and smooth.


The chatter...I've heard it's typical to have that chattering sound if you have a lightweight flywheel, which some people get with aftermarket clutches. Not a definitive answer, but a possibility.

mike-2ptzero
12-24-2005, 12:09 AM
Originally posted by Jonathan ERS4
I pm'ed a member of audizine about this. I also wanted to some of your guys feedback aswell.
This is what I wrote:



Any one know if this is something I should worry about? Is the clutch going bad or is this the way the SPEC clutch is supposed to be? It only has 20K miles on it. My main question and concern is the subtle noise. Is this something I should worry about. Do any of your guys after market clutches make some noise? Thanks in advance for anyones opinions or feedback,

Jon

Sounds like it might be a 6 puck disk with a lwfw. This type of setup can cause high chatter sounds at idle without the clutch pushed in and can a very on/off clutch feel with it being very jerky(not smooth at all) feeling at low rpms since there is NO slip or give once the clutch is fully engaged.

a4rings
12-24-2005, 12:38 AM
dont worry, i have the same setup ad have the same exact problems. The chatter is from a lwfw, and your clutch is hard to drive because it is a performance clutch and you have to rev it to 2k to move because of the lwfw, anything lower then 2k and the car wants to stall.

bitterchild
12-24-2005, 02:13 AM
congratulations, you have the wrong clutch. wrong stage, not application

E Fresh
12-24-2005, 11:16 AM
Thanks kelticslob, mike-2ptzero, and a4rings, This makes me feel better now. I was figuring that my clutch was supposed to be this way, because it doesnt slip and it's really good especially at high RPM fast shifts. also the fact that it has low milage on it. Thanks again, [;)]

jon