PDA

View Full Version : Bulb/Ballast going bad???



CaSp3r9
12-22-2005, 03:48 PM
So I bought McCulloch's 5000k HID Xenon kit about 4 months ago and its been perfect up until today. I noticed that my passenger side headlight was dimmer and darker blue than my driver side headlight. I was thinking that maybe it has to do with all of this rain we've been having here in Portland, Oregon lately. But I checked all the connections, bulb, ballast and igniter and everything was dry and looked good. When I first turn my lights on, I noticed that my passenger side light took longer than the other to heat up/turn on. For the first minute or so, it works perfectly fine - its the same color and brightness as my driver side light. But after that, it clicks and dims down and turns a little bit darker blue. I'm not sure what the problem is but this got me thinking it was my ballast. If so, does anyone know how much this would be to replace?
Here are pics of what the light looks like before and after...
It's not a HUGE deal and it's still plenty bright to be driving around with at night with, It just bugs the hell out of me!

This is what they look like right when you turn them on... how they should look.[up]
http://x12.putfile.com/12/35517513093.jpg

Then about a minute later, the passenger side light does this...[mad]
http://x12.putfile.com/12/35517522225.jpg

RedRocket
12-22-2005, 03:55 PM
To diagnose, swap bulbs. If the problem moves it the bulb, if it stays on the same side it's the ballast. If it goes away, it was part of the connection.

CaSp3r9
12-22-2005, 04:12 PM
hahah, ooohhhhh yeahh! DUH! Thanks man. I'll have to try that tomorrow... xmas party tonight [:(]

salz2135
12-22-2005, 04:18 PM
the driver side light looks much dimmer even in the first picture.

CaSp3r9
12-22-2005, 05:12 PM
Originally posted by salz2135
the driver side light looks much dimmer even in the first picture.

Yeah... With the lighting it was kind of tricky getting good pics, the angle makes them look different too. The passenger side, in person, is dimmer and darker blue. [:(]

RedRocket
12-22-2005, 08:51 PM
shit, trying to photo HIDs is a pita.

littlewhite
12-22-2005, 10:49 PM
Originally posted by RedRocket
shit, trying to photo HIDs is a pita.

DIng! yea is hard

salz2135
12-23-2005, 07:54 AM
did you switch bulbs yet? results?

Daft
12-23-2005, 08:37 AM
Originally posted by CaSp3r9
Yeah... With the lighting it was kind of tricky getting good pics, the angle makes them look different too. The passenger side, in person, is dimmer and darker blue. [:(]

What brand are the bulbs in that kit? I bet that they are aftermarket ones since Philips and Osram don't really market 5000k bulbs. Philips has them but, they are really scarce.

RedRocket
12-23-2005, 10:17 AM
^^^That is correct. Phillips does have them but they are hard to find. To be honest, many 5000k bulbs are actually burnt in 4100k bulbs. I think they actually say on the side of the bulbs "4100+".

With the kit you have I bet they are not Phillips bulbs.

littlewhite
12-23-2005, 01:46 PM
i have 6K bulbs that i'm taking out soon if u r interested in them.

CaSp3r9
12-23-2005, 06:08 PM
I'm not sure who makes the bulbs, but the kit is made by McCulloch. I just finished taking apart everything and switching the bulbs. The problem moved, so that means my bulb is going bad, which I kind of figured because when I looked at the bulb itself it had a blackened chrome mark on the side of the glass tube. I'm glad my ballasts are still good [:)]
Also, does anyone know if I'll be able to use any HID bulb with my McCulloch ballasts/igniters if I choose to switch them out later on down the road?
Thanks for the responces guys!

blackknight - No thanks, the bulbs are still under warranty as I just figured out, so I'll just get a new one for free [:)] 6000k bulbs are a little too blue for me anyways, I like the stock HID look.