PDA

View Full Version : CEL secondary air injection 2.8 V6 what to look for?



yusoslo
12-21-2005, 09:00 AM
I was driving last night 22 degrees outside, and at a stoplight my car dips in rpms for a single second, just enough to let me look at the dash and the CEL comes on, after that it idles fine and drove great.

I have the code cleared at autozone and it hasnt come back on.
I know this pertains to the combination valve and the secondary air pump. Where are these on a 2.8 30V V6?

I will look for cracks in the hoses if I know where they are, but if the light doesnt come back on than it was just a fluke then, right?

I really hate how these things throw CEL lights like a whore spreads her legs.
I think the ecu should let things like emmsions go 1,2, and on the 3rd time show the light, now things like timing and missfiring I want to know but emmisions it should hold of and see if the problem persists again.

anywho, I just want to know where this is and what would be the worst case if the light comes back on...i could still drive it I assume for a few weeks until I feel like fixing it.

k0mpresd
12-21-2005, 10:40 AM
there is a black plastic hose that runs from each side of the motor that runs around the back of the intake..they are really bad about cracking..id check that hose

yusoslo
12-21-2005, 10:46 AM
i will check when i get off work. Are you saying the back of the intake manifold or the intake elbow?

I look back there on my luchbreak without taking off the engine cover, it seems to be most of the hoses look to be around 3/8 to 5/16" does that seem right, this is just a guess.

A4_Andre
12-21-2005, 12:19 PM
i had that problem... check your vaccum lines like was mentioned before. couldnt it be the MAF as well?

yusoslo
12-21-2005, 04:09 PM
I do have a short ram LLTEK intake, but its been forever since I oiled the filter so I doubt that caused the MAF problem if there is one.

But the car runs great and the light hasnt come back on yet, so I am hoping it was a fluke.

njtrackstar
10-16-2007, 09:09 AM
bring back this dead post. If its possable can someone take a picture and show in the picture what lines to check for the leak. I have the same noise (kind of like a jet engine sound) I am notsure what line everyone is talking about to check. Thanks

njtrackstar
10-17-2007, 03:53 AM
anyone?