PDA

View Full Version : Overspray's A4 - DD Project (for now)



Overspray
03-18-2017, 06:52 AM
Hey guys, been lurking for a while now but finally registered and ready to introduce myself. I'm from SE Michigan, and just picked up a 1999 A4 Quattro 1.8t to use as a daily driver. Would have preferred a MT but for the deal, I can handle having an AT. 122k on the clock, pretty clean with typical wear and tear, and had a misfire issue that I've been diagnosing, and I'll basically end up "restoring" a lot to original. I love to mod, so most mods will be for reliability, ease of maintenance, etc. possibly some stuff to move it a bit quicker.

The PO states he did the timing belt (ill be doing that shortly to make sure), as well as new coils, plugs, and ICM. It had a Spectre cone filter on it, but I have since replaced the stock air box with a drop in K&N and cleaned the MAF. I deleted the ICM and updated the coils to 2.0FSI with a kit from 034Motorsport as well as plugs (found one electrode had no gap, not sure how that happened) Tomorrow I'll be doing their breather tube/billet PCV update also and this week will be silicone vac hose replacement time.


From there I still have the typical ABS module bullshit and possibly a wheel sensor, blown speakers (bose concert), various oil leaks etc.


Anyways, I'll post some pictures this evening since I can't seem to from my phone.

Overspray
03-27-2017, 04:28 AM
Well it's been a few weeks since I purchased my first Audi, and it's been a big learning curve trying to diagnose all of the damn lights and misfire codes.

Here she is the day I bought her:
http://i1285.photobucket.com/albums/a594/Stanghe06/449C2813-554C-4656-834C-B9C81F33AC95_zpsgbna2tjs.jpg

Got her home, misfiring pretty horribly, and setup for some wrench time:
http://i1285.photobucket.com/albums/a594/Stanghe06/F0B98111-26E9-4105-B955-A86F89A11DE7_zpsxqhcsnzl.jpg

Plenty of codes on the ECU, mainly random multiple cylinder misfire, cyl 1 and 3 misfire, etc etc. all of the typical stuff I've read about. So, I deleted the ICM, upgraded to 2.0FSI coils, new plugs, replaced the breather/PCV setup with the silicone 034 Motorsports kit, new vac lines from DV to intake and intake to FPR, and a new piston style DV. Id assume this caused my cyl 1 misfire.http://i1285.photobucket.com/albums/a594/Stanghe06/C1C3BCFC-B9A5-4F9E-93D7-FD0A419DC7A8_zpsl9twmaaj.jpg

Seems like every time I repair something, the car runs much better. I can take it out on the highway and stop and go traffic and she runs well. Doesn't seem to run rich or lean on the VCDS, and throws no codes. But when I take it to work on Monday, she throws a CEL for multipie cyl misfire and cyl 3 misfire. Kind of starting to drive me crazy. Where should I look next?!?

b6Hate4
03-27-2017, 04:34 AM
With new plugs and ignition coils, I would look to the injectors. Swap the injectors between cyl. 3 and 4 and see if the misfire follows.

Overspray
03-27-2017, 06:06 PM
Just gave that a shot b6hate4, found that injector #2's wiring is missing the metal clip to hold it to the injector, it was zip tied on.http://i1285.photobucket.com/albums/a594/Stanghe06/181EFBC5-F35D-4F4A-ACA0-3F752016C8AE_zpsobxifutr.jpg

From there, I pulled the injectors to swap #3 with #2. Well #2 is a bitch again and fell apart, left the O-ring in place. And the cap? cracked and fell into the head. So I spent the better part of an hour MacGyvering some tools to remove it, with success.http://i1285.photobucket.com/albums/a594/Stanghe06/75094060-CFAC-4964-8B7F-AC485E59C262_zpsb180s94a.jpg

Seems like a lot of issues with cyl 2. Is it possible the misfire is reading incorrectly? Also, I need a new injector now, should I upgrade the set in plans of future mods/e85 tune?

Overspray
04-03-2017, 05:08 PM
Well I went ahead and just replaced the fuel injectors with stock, no upgrade or tune for now. I need to get this thing running correctly before going further with any fun. That was a waste of money anyways. Still getting codes for multiple cyl misfire and cyl 3 misfire. I'll swap the coils tomorrow just to check and see if the new ones are bad, but I doubt that. What should compression range be on all cylinders? I'll get on that next. It only seems to misfire at idle or very low RPM.

PringlesInVic
04-03-2017, 10:52 PM
Got her home, misfiring pretty horribly, and setup for some wrench time:
http://i1285.photobucket.com/albums/a594/Stanghe06/F0B98111-26E9-4105-B955-A86F89A11DE7_zpsxqhcsnzl.jpg


Sorry, can't help you with the misfire as you've tried all the things I would have suggested already. But I'd love some more info on your lift. Seems great for a small garage. Hydraulic?

Overspray
04-04-2017, 03:29 AM
Pringle, it's a hydraulic midrise hoist. Yes, my garage isn't very large (22x22 detached) with crap concrete, crap foundation, crap build, and storage for everything you could think of. I'm waiting on drawings right now for a new attached garage build that will be much larger. I'll end up putting that hoist in the ground so it'll be flush.

Davdraco1
04-04-2017, 03:58 AM
I wasn't getting codes for misfires, but I was wachting them occur while driving and had VCSD hooked up. My primary o2 sensor was incorrectly reading rich so it was cutting fuel when it wasnt supposed to. Just another thought.

Overspray
04-04-2017, 04:02 AM
How did you come to that diagnosis Davdraco? In VCDS all measuring blocks that I've been monitoring seem within parameters that I've been reading.

HumbleTurbo
04-04-2017, 04:20 AM
Man, I wish my b5 had 122k. Nice buy! Other than all that misfire nonsense, u will get it worked out though.


Sent from my iPhone using Audizine (http://r.tapatalk.com/byo?rid=87676)

Davdraco1
04-04-2017, 04:36 AM
The car would run fine until it warmed up, the lambda reading was almost -30 or whither is extremely rich. I could watch the misfire counter in VCDS just start to rise and it was on all cylinders. I figured it wasn't reading right and it was pulling fuel. I switched it out and fixed. Lucky guess I guess

Overspray
04-04-2017, 07:32 AM
My lambda readings are all fine, nothing way off like that. Maybe later I'll build a boost leak tester and see if I can snag a compression tester from work. My area of expertise is paint and body, I'm no slouch with a wrench but actually diagnosing multiple in depth issues is new to me.

Overspray
04-05-2017, 03:54 AM
Another round of fun. Moved coils from 3-4 just to make sure the planets didn't align and I didn't receive a new coil that was bad AND just happen to put it on cyl 3. Still Cyl 3 misfire. Pulled all of the new plugs, all look even colored and dry, turned the engine over until the upper cam mark aligned with the valve cover, the crank mark was off slightly to the left (counter clockwise), but I've been advised this is normal as when doing the timing belt, the cam gears will be perfectly aligned. Had an issue with cyl#1 034 Motorsports ICM delete harness, installed a replacement yesterday and no difference again. Still a cyl 3 misfire code, I can watch the thing misfiring at idle only, driving is fine.

Is there anything else I'm missing? Hoping to check compression later today and possibly build my boost leak tester this week.

PringlesInVic
04-05-2017, 09:37 AM
Do you have access to a borescope? I think the compression test should shed some light on the situation.

Overspray
04-08-2017, 12:08 PM
Compression test definitely shed some light on the situation. Cyl 3 is at 70psi, jumped up to 90 with some oil put in there. Well that sucks. Guess I'll have to figure out what to do with the car now.

HumbleTurbo
04-08-2017, 05:16 PM
Motorswap


Sent from my iPhone using Audizine (http://r.tapatalk.com/byo?rid=87676)

Overspray
04-09-2017, 11:54 AM
Ah yes, the engine swap. I'd love to go LS but it won't happen. I bought this car to replace my Turbo diesel Chevy cruze, as I'm sick of payments. Once that sells I'll probably source another b5 A4 to have around when this one dies. Maybe make one good one out of two bad ones.

PringlesInVic
04-10-2017, 10:59 AM
That sucks. Keep your eye open for another B5. Or perhaps a C5 A6 part out and V8 swap it.