PDA

View Full Version : Wrong / faulty temperature sensor ?



KeyserSoze
12-11-2016, 06:01 AM
Hi all, i'm new here. [:)] Just changed temperature sensor on my 98' A4 B5 1.9tdi 66kw AHU yesterday, because the old one started to fail. I've got OE sensor number 059 919 501 (though not from Audi dealer, just regular parts store). Everything else seem fine, but temperature gauge now only showing slightly above 70c and ECU is seeing 81c at highest (checked that with BT adapter and smart phone). Now i'm wondering whether the sensor is faulty OR could it possibly be wrong part and i need different one?
I've accidentally dropped the old one down on the bottom engine cover before getting chance to see any numbers on it, though i remember it being blue (new one are green). From what i could gather, original sensor for this car should be blue and have code 078 919 501 , while newer one 059 919 501 are green, but it replaces the old one and should work. ETOS program also showing temperature sensor as 059 919 501.
Since i can't undo my lower cover right now and look at the old one, i wonder whether it's possible that i need sensor with different code or mine's just faulty?

Luis_Heineken
12-11-2016, 06:55 AM
https://www.ecstuning.com/Search/SiteSearch/078_919_501/
https://www.ecstuning.com/Search/SiteSearch/059_919_501/

seanf86
12-11-2016, 07:27 AM
you know what brand it is? I bought one from the local parts store and it was uro parts reboxed crap, same problem as you describe. I was changing mine for preventative maintenance so I threw the old one back in. I would say your best bet is going to the Audi/VW dealer and buying an OE one even if it costs more.

KeyserSoze
12-11-2016, 08:37 AM
you know what brand it is? I bought one from the local parts store and it was uro parts reboxed crap, same problem as you describe. I was changing mine for preventative maintenance so I threw the old one back in. I would say your best bet is going to the Audi/VW dealer and buying an OE one even if it costs more.

It has no brand on it, just says "made in Luxembourg" and has 059 919 509 on it. Looks kind of like OE part should look as far as i know. [confused] Don't see myself buying such thing from the dealer, as much i love my car, just looking to find reasonable brand that would do the job. [rolleyes] Probably gonna buy 31539 Febi and try my luck. [:/]

B5 Gang
12-11-2016, 06:09 PM
If your sensor was blue, get the blue one. If it's green get the green one

KeyserSoze
12-13-2016, 09:38 AM
Just a quick update: I've got myself 31539 Febi and it works like a charm. [:)] 059 919 501 was indeed good OE number, and color doesn't matter (Febi i've installed are green as well, not blue as original), my "OE" sensor simply was some cheap rubbish and faulty. [:)]