PDA

View Full Version : Clutch Pedal



woolveren
02-14-2016, 07:51 AM
My 98 AEB's clutch pedal is having too much free play as you can see in the below video. There is very little resistance to push the clutch pedal all the way down and it engages at a very low point as well causing occasional shifting difficulties. It's been like this for almost a month now(even though minor symptoms were there for about an year), the brake fluid level was never dropped so I think the master cylinder is okay? I have also tried to start out at 2nd/4th gear and the car immediately stalled so I believe clutch itself is fine too. Can someone please suggest where else to look for problems?


https://www.youtube.com/watch?v=dSjcWr2koJM

woolveren
02-23-2016, 08:34 PM
Nobody replied the thread, but thought of updating.

Both master and slave cylinder were having internal leak. They are now replaced with new Sachs units and clutch pedal is all good now. But now I hate the extreme high clutch engagement point. [:)]

bmos
02-24-2016, 06:31 AM
Nobody replied the thread, but thought of updating.

Both master and slave cylinder were having internal leak. They are now replaced with new Sachs units and clutch pedal is all good now. But now I hate the extreme high clutch engagement point. [:)]
Yeah, I'm not a fan of the engagement point either. Reminds me of my dad's Toyota Tacoma I learned to drive stick with.

I think you can get custom clutch setups to change it which I'm going to look at when I replace mine.