PDA

View Full Version : Help please! Car won't stay running!



Cactus Avant
11-25-2015, 11:07 AM
So I have been gone at school, and my car (1999 1.8tqm AEB) had a dead battery. So I jumped the car, drove it for a few minutes, then it started sputtering and died. Tried to jump it again, ran for a few minutes, sputtered, and died. This keeps happening, and sometimes I can't get it to start at all. I've been searching for answers online for 3 days now, and can't figure it out.
I have replaced
Fuel filter (1k miles ago)
Spark plugs (2k miles ago)
Alternator (10k miles ago)

I found a fuel injector had a crack in it, but I just replaced it, and I am finding no difference. Check engine light is on, and these are the codes Im getting:
P1602 terminal 30 voltage too low
P1136
P1476
P0300
P0301
P0302

I'm beginning to think it may be the ICM, or bad coils? Is there a way to check? Any ways to easily check the fuel pump? I am super confused. The car smells like gas so I am assuming it is getting fuel. And when I changed the fuel injector, there was definitely a lot of fuel.

Anything would help greatly! Thank you in advance!!

LA4
11-25-2015, 11:17 AM
The fuel pump should make a noise when you turn the ignition on (not starting the car, just flipping the key to on.) It's audible if you stand outside the car near the trunk.

I guess ICM. You could try swapping a junkyard one, but you don't really have a way of knowing if it's good. I may have one lying around in my spare parts bin too...... Although if that's the problem I'd just delete it and upgrade to the newer coils, it's what I plan to do when mine finally shits the bed.

Cactus Avant
11-27-2015, 12:27 PM
Now I put in new plugs, checked the ICM and its good, and now I'm just super confused. Anyone have any ideas?

Cactus Avant
12-22-2015, 12:35 PM
Okay guys,
Changed the spark plugs
New fuel pump
New fuel filter
New fuel pressure regulator
Tested ICM
Changed crank pos sensor
Tried running with MAF unplugged
Changed coolant temp sensor
Changed air intake temp sensor

The car will start, run for a minute or so then die. Any ideas?

Seerlah
12-22-2015, 02:55 PM
It runs, which is a good sign. Next, you need to monitor a few things before it dies:

Fuel pressure
G/S MAF readings
Bettery voltage
Coolant temp

In a nutshell, you have combustion. Now you need to figure out which of three (spark, fuel, and air) is causing you to lose that. Spark and fuel is what you want to be concentrating on, since it sounds safe to say you have compression (should check this too, regardless). Things listed above is what I can think of for spark, fuel, and air mass of combustion to check. Hopefully others chime in with some advice.

Cactus Avant
12-30-2015, 03:09 PM
Problem solved:

I did the 2.0 coil conversion/ICM delete, and now it stays running! Its not making power from boost though.... I'm hoping thats just the old gas/Heet in there now

Weird because the car ran really well when it did run before. And the ICM tested good. I don't know, but I'm so excited it runs again. First time driving in 3 months

Seerlah
12-30-2015, 03:15 PM
My car has sat for like a month and a half. Used to stuff like this. No battery, needs t3 gasket (picked up a while back), and pure procrastination is a bad combination. Hahaha!