PDA

View Full Version : Car finally back w/ new engn



VtAudi
09-19-2005, 03:18 PM
So I finally got my car back, runs great, sounds solid, a ? though.
w/ a new engn, do I have to do anything as far as rebooting or doing something w/ the ecu since its a different engn now? I have some O2 sensor stuff coming up (1198) but the shop is going to pay for that also, they think they fryed or damaged in w/ the install.

nizmosx
09-19-2005, 03:23 PM
no but i feel you should break it in like i did mine. actually im still breakin it in.

SeanF
09-19-2005, 03:38 PM
his was a used engine..

nizmosx
09-19-2005, 03:45 PM
ohhh i thought you said new engine

SeanF
09-19-2005, 03:51 PM
new to him, i believe the shop got it used from shokan.com

MR VTEC
09-19-2005, 04:31 PM
i would still break it in... you don't know how long it has been sitting in the yard.

Hassmeister
09-19-2005, 04:38 PM
Ahh, just drive it like it was stolen.

VtAudi
09-19-2005, 04:46 PM
It was a rebuilt eng from Shokan that they just finished, so whatever rebuild means, I know it has all new belts and waterpump, and it was all shiney before they put it in.... they told me to change the oil after 1k, and take it easy on the rpm's for a while, one thing I noticed that was wierd, my antifreeze is green??? do they have green antifreeze for aluminum radiators? If not I need to ask them about that.....

94jedi
09-19-2005, 04:59 PM
I would break it in like a new engine just to be sure. Also, like they said, change the oil after about 800-1000. I know that sounds anal but for as much as a new engine costs, I know I would be very careful w/ it.

jent
09-19-2005, 05:57 PM
Originally posted by VtAudi
one thing I noticed that was wierd, my antifreeze is green??? do they have green antifreeze for aluminum radiators? If not I need to ask them about that.....

If there is I have never heared of it....there is some kind of fluid that is g12 but not red, but I don't think it is green. Could be wrong on this one but thats what I seem to rember.

MR VTEC
09-19-2005, 06:00 PM
some antifreezes say they can be mixed and won't detriorate the radiator but i don't know.

VtAudi
09-19-2005, 06:01 PM
Originally posted by jent
If there is I have never heared of it....there is some kind of fluid that is g12 but not red, but I don't think it is green. Could be wrong on this one but thats what I seem to rember.

If its "regular" green, isnt that bad? What will it need just a flush?

jent
09-19-2005, 06:09 PM
yea if it is infact not the fluid you need it will just need a flush as long as it hasent been in there for a super long time, like i know yours has NOT :-)

VtAudi
09-19-2005, 06:13 PM
Ya... just 2 days : )