PDA

View Full Version : Ignition Switch and or Relay (213/370) Issues.....



Ryanic
03-28-2015, 05:58 PM
1998.5 A4, 2.8L

Alright so I have no headlights, brights, turn signals, wipers, horn, ambient air temp, front or rear fogs, rear defrost, and my fan doesn't work.

I do have, running lights, if I click the brights forward to keep them on all the time they do not go on, but if I hold it back towards me they will go on as long as I hold the lever.

Did some reading online and the general census was that it was either a bad ignition switch or a 213 relay (or 370 relay if i had the newer one)


Now here is what I've tried so far with no luck.


I swapped out the 213 relay for an extra 213 relay i had from a parts car, No luck.
I swapped out the 213 relay for an extra 370 relay I had from a parts car, No luck. ALTHOUGH when I had the 370 relay in and I had the car on, if I had my wipers on and then pulled the brights lever towards me, the brights would come on AND the wipers would move as long as I had the brights pulled back. As soon as I stopped pulling the brights towards me the wiper would stop and the brights would turn off.
I swapped out the ignition switch with an extra that I had from a parts car (I have no reason to believe that ignition switch was bad also), No luck.
Checked all fuses for shits and giggles. No bad ones
Swapped out all the other relays one by one and tested them each time under the dash for shits and giggles. Nothing changed.



What is there left to check?

On my way back from work none of my stuff was working and then randomly for about 2 seconds I saw my ambient air temp gauge come back on, on my gauge. I figured maybe it started working again so I tried turning on my headlights to see if it randomly fixed itself and as soon as I turned my lights on it killed the ambient air temp gauge again... Nothing worked again.


I need this fixed ASAP, as I need to drive my car at night... And I mean I could just hold the brights on 24/7 but that'd be annoying to other drivers and dangerous...

Ryanic
03-29-2015, 11:18 AM
Anyone????

Ryanic
03-29-2015, 12:42 PM
Figured it out...looked closer at my switch and found melted plastic on one of the contacts, Looked at my connector then and saw more melted plastic. Cleaned out the connector as best as I could and it works for now. Just need to figure out how to replace that connector now.