PDA

View Full Version : Need help for cruise control, cruise control cannot turn on, 97 2.8QM



leoliu041892
02-12-2015, 07:14 PM
Hi, the car has been like this since i got it.
The previous owner( second) told be the cruise control never work before, he has no idea too.
So when i try to activate cruise control by pushing the switch on left flasher, nothing happen, no light no any indicator on cluster. I also tried to set the speed, nothing happen.

I checked the fuse box, the fuse is good ( climate control sharing the same fuse, and the Ac/ heat works fine).
Under the hood, the vacuum line that on the actuator is detached, and hanging around engine block.
The other end of vacuum line is covered with grease that should be from power steering leak ( over filled by previous owner).
I did not see the vacuum pump, because it's dark already.

Any thought? Would that be the problem from control module?

Thank you!

woolveren
02-12-2015, 08:43 PM
Could be a bad CC module or stalk switch.

Read this thread.. post #8 to #25
http://www.audizine.com/forum/showthread.php/477068-Can-I-drive-without-the-Cruise-Control-Module

pbcrazy
02-12-2015, 08:56 PM
Welcome to the club. It could be a vacuum hose (as the system is completely vacuum operated), the control module, or the stalk. Try flipping between on/off on the stalk a ton of times and see if it works after (corroded stalk). Test for vacuum leaks. If nothing works, it could be the module itself, but they are quite pricey and not a common used part as the CC on these cars fail more times than they work.

leoliu041892
02-12-2015, 10:26 PM
Thank you for replying, I'll try these tmr!