PDA

View Full Version : 2.8 quattro engine code help (01257)



Hayden93
01-21-2015, 04:20 AM
Good afternoon, can anyone help me with the following engine code? I'm not sure if im reading it wrong or just plain stupid. [confused][confused]

01257

I've looked online and on anther site it says test N71? What does that mean? [rolleyes]

Nakadah
01-21-2015, 05:46 AM
P01257 - Idle Speed Stabilization Valve (N71)
-Short circuit to positive
-Open circuit / short circuit to earth

N71 is rotational valve with coil motor (drived by PWM signal from the ECU). This valve is electronically adjusted air screw :)

You must check valve for internal short circuit and also the wiring from the ECU to the N71 valve. If valve is broken, buy a new one.

Your car is 2.8 V6 12v (engine AAH) right? Look on this:

http://resize.like.cz/images/82_209_59_175_21-01-15-02-45-36_1421847936N71.jpg

Hayden93
01-21-2015, 09:11 AM
That seems complicated haha cheers mate [hail]

Nakadah
01-21-2015, 10:14 AM
Complicated? No, I think not. Use DMM to check resistance between two pins in N71 on the valve body. Specified value is 7 to 11 Ohms. If will be valve OK, you must check the wirings. From pins in valve connector to the connector at ECU.
But I dont have wiring scheme for your car :(

This would be easy work for me, but I am too far from England. Good luck man [;)]

Hayden93
01-21-2015, 03:10 PM
Thanks for your post though, like you said it shouldn't be too bad; I think it looks worse than it is.

I'll have a look at it tomorrow and will report back.

Hayden93
01-22-2015, 01:22 AM
Before I start stripping the car I had a quick look through the cars history and I've found a few bits that might help with this situation?

20/12/2012 @ 151k miles :: Exchange ECU Unit + ECU Testing
17/12/2013 @ 175k Miles :: Fit new vac pipes and clean Idle control valve
24/02/2014 @ 177k miles :: Fit new idle control valve


So its had an ECU replacement and had a new Idle control valve, the car is on around 185k now so surely it wouldn't need a new one after just 10k miles?

Hayden93
01-22-2015, 05:05 AM
Sorry for the multiple posts but I noticed the previous owner has cut the pipe between the air-box and engine down causing it not to be a snug fit for some reason. Could this be the cause of the issue?

Nakadah
01-22-2015, 05:15 AM
Buy DMM and do what I wrote above.

Check valve and wirings.

http://www.audi-club.ru/forum/attachment.php?attachmentid=38911&d=1147000858

Here is full procedure with pictures [;)] even trained monkey can make it. Dont be afraid.

Hayden93
01-22-2015, 05:28 AM
Buy DMM and do what I wrote above.

Check valve and wirings.

http://www.audi-club.ru/forum/attachment.php?attachmentid=38911&d=1147000858

Here is full procedure with pictures [;)] even trained monkey can make it. Dont be afraid.


Okay thank you for the post! But just before I do that is there any chance its related to my pipe? You can clearly see its not the correct one for this car.

Also, any DDM you recommend?
http://i61.tinypic.com/11gswhj.jpg

Nakadah
01-22-2015, 07:52 AM
For example Uni-T UT33D is small, good and accurate DMM (~10 GBP on ebay). Why you have disconnected suction hose from airbox?

Hayden93
01-22-2015, 08:58 AM
That's how it was when the code flashed up, it's not the right hose so it don't fit. I

've just bought a new pipe will test it when I get home.

Nakadah
01-25-2015, 01:31 AM
Any news?

Hayden93
01-25-2015, 04:03 AM
Yeah I located it and cleaned it off but nothing so going too check the wiring as soon as tpmy DDM arrives :)

Also I thought I had the 2.8 when it's only the 2.6 [>_<] not sure if that makes much difference?