PDA

View Full Version : Port status: ok, Interface: found, but "No Response From Controller!"



4ringsA4b5
01-17-2015, 12:08 AM
Ok so before i even start, im already prepared "ebay cables, blah blah blah".. But heres the thing. I purchased a 2001 a4 awm a few weeks ago. Only paid $1200 for it. Awd, runs good, only needs a heater core... I couldn't pass up on the deal. So when i first got it the check engine light was on, I tried to connect my ebay cable that works on my 1998 with the same laptop and was unable to connect, Port status ok, interface not found. I then took it to autozone and their scanner was also unable to connect. I am pretty familiar with the way things work, I have the factory stereo installed and everything. Tore the car apart tracing wires. Couldn't find any problems. Finally got my laptop to connect on my 2001 by just slightly putting the cable into the obd2 port but not pushing it in all the way. As soon as you push it in all the way it is unable to connect again. So anyway i scanned the car with the cable slightly inserted and came up with a few codes for 3 of the coil packs, and cleared the codes because i know that the coil packs were replaced the day before i bought the car so i figured its just old codes.. 3 weeks and 500 miles later the check engine light comes on again. This time i try to connect my ebay cable using the same vcds lite and came up with port status ok, interface found, i apply and save settings, Go to launch the engine [01] and it failed to connect 4 times before it gives me a error saying "no response from controller!". Again autozone is unable to connect and at the same time, this cable, program and laptop all work on my 1998 aeb. I'm going to mess with it some more tomorrow. I read that unplugging the ABS and plugging it back in might allow me to connect to the diagnostics. I know that when i purchased the car, the fuses for the abs controller were removed. I haven't installed fuses (i think there is 2 missing). I have read multiple threads were people were also getting the same error but yet to find the solution. Everybody reply's with "buy the real cable and you wont have this problem".. I'm pretty sure the real cable wouldn't help me in this situation. Any input?

seanf86
01-17-2015, 05:03 AM
when the abs module takes a dump sometimes you have to physically unplug the connector from the module under the hood for vcds to connect

xdewaynex
01-17-2015, 06:04 AM
My abs has been unplugged for at least 4yrs now because of this. I also snipped the K line wire (forgot which one) in the stereo harness since I got the car without a headunit and installed an Alpine unit.

richardodn
01-17-2015, 06:10 AM
Also make sure you have good battery voltage. Low voltage can cause odd issues.

4ringsA4b5
01-17-2015, 11:04 AM
Unplugged my ABS connector under the hood but it didn't seem to make a difference. Switched batteries with my other car and still no luck. Maybe something is wrong with my obd connector under the dash