PDA

View Full Version : 2.7t swap need help on vag connect



wooster a4
01-11-2015, 09:30 AM
I'm doing a swap on my 99 A4 1.8t pre facelift. Putting in a 2.7tt with no immobilizer. Please skip all of the "just bye an S4" comments. Engine is mounted everything is hooked up and runs. I put the AEB body plugs on the APB harness. I cant connect to any module with vag. The engine had 1 k-line wire that connected to the matching color (green) k-line on car. The car has a white/ black stripe k-line wire with no home on the ecu. The ecu (from a 2.7tt) has the high low can bus wires. How do I integrate the can bus to the car? Goal is no check engine light and pass all readiness tests so I can pass CA smog. not to worried about things like cruise control. To late to turn back now just need a solution. Clearly the car wants more money from me

Bordom
01-11-2015, 09:57 AM
PICS?

Mad Cow
01-11-2015, 05:59 PM
Cruise control is cake, all you gotta do is connect the right wires to the ECU since it's all self contained. You won't get the canbus working, don't even try. If you can't connect to any modules you connected the k-line to something that isn't the k-line, figure that out and you're golden. To fully get rid of the CEL you'll need to mess with the ECU tune. It's not difficult but you'll need to do quite a bit of reading, the nefmoto forums will be your best friend here. I've got my DBW swap mostly buttoned up, no CEL, runs properly, everything but ASR works, and it passes every readiness monitor.