PDA

View Full Version : 99 audi b5 misfire after changing sparks and coils



mention17
12-29-2014, 07:57 AM
I have 99 audi a4 with a GIAC chip. A month ago, my car started sputtering and misfiring badly a low acceleration and at idile. The cel light came on, and it would sputter or shake at low acceleration, and cel light would blink. I had it scanned and it said a misfire on cyl 1 and 2. I bought new spark plugs and replaced coilovers 1 and 2 with new ones. I gapped the spark plugs to .028. Once they were replaced, it still sputtered and idled rough. Codes were saying it was misfiring on all 4 cylinders.

I took it too a mechanic and he scanned it and it said it was misfiring on all 4 cylinders. He replaced all four spark plugs and switched around the coilpacks and scanned again. It said a cylinder 1 misfire and still sputtered at idle. We then checked a ground control wire on near cylinder one, and it was not giving any spark. He then switched to another ground control and let it run. It stopped sputtering and he deleted the code. I drove home that day and had no cel light came on. The next day on my way to work, I was driving and i put it in 4th gear and it started misfiring. When I came to a stop, the light came on and it began to sputter again. I am out of options. I need help.[o_o][evilsmile][evilsmile]

mention17
12-29-2014, 08:22 AM
1.I bought ngk Bkr7e spark plugs and gapped them to .028 and bought beru coilpacks and replaced them when i first got them scanned. I then took it back to get it scanned and the codes were reading a misfire on all 4 cylinders. That is weird since the spark plugs were new and it would not even drive if all were misfiring.

2. took it to the mechanic and he put ngk iridium plugs in it and it still sputtered and showed a misfire on cylinder 1. Switched ground control wire and drove fine the rest of the day.

3. next day started misfiring in 4 gear and cel light blinking

RallyeBourne
12-29-2014, 09:31 AM
I would guess ignition control module.

Rodgman15
12-29-2014, 09:45 AM
Excellent. ^^^ That was my suggestion on his thread over on vortex.

pyongwonse
12-30-2014, 12:06 PM
isnt icm normally related to cyl 2 misfire?

harrowb5
12-30-2014, 01:39 PM
I would guess ignition control module.

I second this

mention17
12-31-2014, 09:20 AM
Come to find out that it was indeed the ICM that was causing the misfire on cylinder 1. After ordering from europaparts.com, i swapped out my old icm with the new and havent had a misfire since! Thanks guys.

harrowb5
12-31-2014, 09:29 AM
That's great brotha have fun driving the car and have a happy new year

RallyeBourne
12-31-2014, 10:03 AM
Don't ... "mention" it...http://tapatalk.imageshack.com/v2/14/12/31/22d36c5907aa05808d50f31e3d139708.jpg