PDA

View Full Version : Heat problems. I actually have motivation this winter



pbcrazy
11-21-2014, 06:56 AM
My heat has never worked worth shit. It will be ~80* when driving when completely warmed up, but it will get colder the longer its on. It also is cold when at idle (at a stop light or something). The system is completely bled, thermostat is good, CTS is new and reads fine, and I flushed the heater core last year with hot water for a solid 10-15 minutes until nothing came out except clean water and the water was exiting as fast as it was going in. It's gunna be real cold this year so I actually care now, anybody have any ideas?

zandrew
11-21-2014, 06:59 AM
I amin the same boat but its colder here. For whatever reason my heat will work fine when it is 50 degrees or higher. When its cold and I turn the heat on I have a squealing soundand sometimes it willwork, most times it does not.

jetice91
11-22-2014, 12:26 PM
Did you flush the heater core backwards and forwards?
Another quick diagnostic check:
With the car fully warmed up and the AC off, set the temp to full cold and make sure recirculation is off. If the air coming out of the vents is decently warmer than it is outside, you have an issue with the blend door.

Corrado_Guy
11-22-2014, 10:20 PM
Low temps in the motor typically indicate a thermostat that is not closing all of the way which makes it very hard to warm up. Try blocking a little bit of the rad and see if this brings the temps up a bit. If it were just heat I would look at the heater core or mode doors but if the motor is cold it sounds like a thermostat that is not letting the motor get warm enough.