PDA

View Full Version : 05 A6 Completly dead Need help????



seiplentz
08-06-2014, 07:26 PM
I just got a 05 A6 as a recovered theft with 46k on it ands it looks brand new. The car ran when it was towed in but the MMI screen was dead. So it sat for about 8 months till I got it. Right now I have the whole interior pulled out due to a water leak which has corroded the Bluetooth module. There is no other visible damage just a little corrosion on the drivers power seat plug.

So right now with the battery connected the key fob will lock and unlock the doors the lights flash but when I put the key in the ignition it does nothing no HVAC controls no instrument cluster or anything??

I spoke to a guy at ross-tech and I was going to the vdcs software but he said he thinks its a key security problem only the dealer can program that. Next I called a dealer about it and they said it wouldn't do that from security problem. They said it would run for a second and shut down if it was a key issue. So who is right?? Or any other ideas.

I don't mind bringing it to the dealer I just know they are going to tell me it needs a million dollars worth of work. Especially since it has evidence of water in it and I have the interior and carpet out of it.

Any input would be greatly appreciated.

rayray
08-06-2014, 07:29 PM
Sound like the ignition switch is bad if you can insert an turn the key.

SinCityA6
08-06-2014, 09:38 PM
It REALLY sounds like a key coding issue. The keys have a microchip that communicates with the car. If that communication is not there, then the car will not even try and crank over. Sounds like the keys need to be recoded which, unfortunately, only the dealer can do.

seiplentz
08-07-2014, 09:22 AM
Thanks for the input. I will be scanning it with a snap-on modis scanner over the weekend. That should at least get me started. I will post the results.

seiplentz
08-08-2014, 03:20 PM
I cannot scan the car. The key will not turn on the ecm???? Any ideas please help??? I have access to alldata and have had no luck on it for the ignition switch. I have a door chime when i put in the key but it does nothing when I turn the key??? It gets locked in when i disconnect the battery. I have checked tons of fuses at 4 different fuse boxes.

SinCityA6
08-08-2014, 06:44 PM
More reason to think it is a key coding issue.....

Dutch_A6
08-08-2014, 07:12 PM
Sounds what I went through a few months back, it was the access control module, they had to replace the steering column. I got in turned the key and nothing, the radio would work but couldn't roll down windows, nor turn on the lights but full battery charge and no error codes coming up. Was a $2500 fix.

put3namo
08-10-2014, 10:51 AM
You can scan the car without turning on the key ... try this > with a full battery charge, Press and hold the brake pedal while turn on the hazard light and high beam keep on doing this while you scan with VCDS it should communicate with the Car then reset the Authorization Module. -Goodluck!


I cannot scan the car. The key will not turn on the ecm???? Any ideas please help??? I have access to alldata and have had no luck on it for the ignition switch. I have a door chime when i put in the key but it does nothing when I turn the key??? It gets locked in when i disconnect the battery. I have checked tons of fuses at 4 different fuse boxes.

seiplentz
08-10-2014, 02:22 PM
You can scan the car without turning on the key ... try this > with a full battery charge, Press and hold the brake pedal while turn on the hazard light and high beam keep on doing this while you scan with VCDS it should communicate with the Car then reset the Authorization Module. -Goodluck!

YOUR THE MAN!! it worked to scan it... I am using a snap-on verus scanner. I think I found a code that may my be causing the key problem 00288 which is a steering column interlock which I just found out isnt locked when I take the key out. The scanner did say I have 2 keys authorized so I should be good with that.

sun_dance
08-10-2014, 02:39 PM
YOUR THE MAN!! it worked to scan it... I am using a snap-on verus scanner. I think I found a code that may my be causing the key problem 00288 which is a steering column interlock which I just found out isnt locked when I take the key out. The scanner did say I have 2 keys authorized so I should be good with that.

FWIW, and based upon the code, it appears your issue is similar to the following:
http://forums.audiworld.com/a6-s6-c6-platform-discussion-58/transponder-steering-column-2834070/

Which could mean the same thing Dutch_A6 mentioned...a new steering column :(

seiplentz
08-10-2014, 03:22 PM
WHOOHOOO the car is running!!!! I pulled the steering column down and it started!!!!!! Its prob intermittent so it will need to be replaced but at least I know what it is now. Than you everyone for the help. Now to trace down the dead mmi screen..