PDA

View Full Version : Radio randomly turning off and no backlight



OldAudiA4
02-13-2014, 04:12 PM
Just wondering if anyone has had the problem of the radio turning off by itself after approximately 1.5 hours of driving. Seems to do it around the same time everytime. Is it a timeout setting? Similar to a sleep setting on a TV?

Also in the display that shows the radio station frequency, is that supposed to have a backlight to illuminate it at night? As while driving at night, the only way to see what frequency is displayed it is to turn the interior light on.

I have a pre-facelift B5.

Luis_Heineken
02-13-2014, 04:42 PM
for me its a bad radio. i have a (simphony) b7 radio for sale. pm me if needed. good luck

Mad Cow
02-13-2014, 04:54 PM
Does the radio come on when you turn the car on and shut off when you turn the car off? These radios are a bit weird in that you can turn them on even with the ignition off, but they time out eventually and turn off to preserve the battery. There were 2 styles of pre-facelift radios, I don't know squat about the earlier style, but the later one with the volume knob in the middle should illuminate all the buttons and screen with the headlight switch. I'd start with pulling the radio out and looking over the harness and plugs.

Luis_Heineken, quit trying to peddle your crap, take it to the classifieds. A B7 symphony won't even fit in a pre-facelift centre console, even if you did get it to fit you'd have to mess with the wiring and install a canbus simulator, otherwise it'll have the exact same issue as OP is having right now.

OldAudiA4
02-13-2014, 10:36 PM
Does the radio come on when you turn the car on and shut off when you turn the car off? These radios are a bit weird in that you can turn them on even with the ignition off, but they time out eventually and turn off to preserve the battery. There were 2 styles of pre-facelift radios, I don't know squat about the earlier style, but the later one with the volume knob in the middle should illuminate all the buttons and screen with the headlight switch. I'd start with pulling the radio out and looking over the harness and plugs.

Luis_Heineken, quit trying to peddle your crap, take it to the classifieds. A B7 symphony won't even fit in a pre-facelift centre console, even if you did get it to fit you'd have to mess with the wiring and install a canbus simulator, otherwise it'll have the exact same issue as OP is having right now.

It doesn't come on and off with the car. I must have the earlier style as my volume knob is not in the middle. All the buttons illuminate with the headlight switch, just not the screen. I'm not too worried with it turning off after a while as you just flick it back on, but just wondering if the small screen should also be illuminated with the headlight switch.

Mad Cow
02-14-2014, 07:57 AM
My guess is it should illuminate, but if the buttons light up then it's likely an internal problem. The other issue is definitely something to do with the switched 12v connection.

timtaz417
08-12-2014, 12:44 AM
I'm having the same problem on my 2011 Audi A3 (Concert)

Does anyone have any solutions?

https://www.youtube.com/watch?v=l1BKN313PSY