PDA

View Full Version : 3 codes, 2 videos, 1 CEL



Nevalite
10-28-2012, 08:09 PM
Hey everyone,

So I am having some engine troubles (amongst others) and I really want to get this sorted out before winter strikes. I have a CEL which I scanned and came up with these codes:


17522 - Oxygen Sensor B1 S2 Internal resistance too high P1114, intermittent
16795 - Secondary Air Injection System: Incorrect Flow Detected P0411
16712 - Knock Sensor 1 (G61): Signal too High P0328, intermittent


The 17522 is just the rear O2, I have had that for a while and plan on changing the O2 sensor next time I work on the car.

The 16795 I believe is being cause by this broken hose:

http://i280.photobucket.com/albums/kk174/nevalite/IMG00281-20121028-1152.jpg



My major concern is the knock sensor, I am not too experience with knocks so I decided to take a video and let you guys hear it.

This first video was taken with the cracked hose left as is:

http://i280.photobucket.com/albums/kk174/nevalite/th_VID00002-20121028-1147.jpg (http://i280.photobucket.com/albums/kk174/nevalite/VID00002-20121028-1147.mp4)

The loud noise seemed to be coming from the cracked hose so I put some duct tape and a tie wrap on there and the loud noise seemed to go away.

Here is a video after the ghetto fix:

http://i280.photobucket.com/albums/kk174/nevalite/th_VID00003-20121028-1158.jpg (http://i280.photobucket.com/albums/kk174/nevalite/VID00003-20121028-1158.mp4)


From what I can tell the loud noise was coming from that hose which I will replace. The second noise seems to be coming from the timing chain area which I think is a bad tensioner.



What do you guys think of all this?

Thanks a lot.

Nevalite
10-29-2012, 04:19 PM
Any input would be helpful :)

Nevalite
10-30-2012, 08:56 PM
Anybody?

kwnk
10-30-2012, 09:09 PM
lol nice temp fix man i had to do the same with gorilla tape, just order another from ecs or maybe a nice silicone one from 034 -- or just stop by audi and pick one up

fix all hoses, check for vac leaks, scan codes, clear codes, and see if they come back

how are your oil levels? set the right levels if its not up to spec
and how does the engine sound @2k rpm? like a machine gun? if not the cct should be okay

id make sure all vac leaks are sorted and oil levels are proper first

maybe its the video quality but the engine sounds okay....at idle at least

Nevalite
10-31-2012, 04:46 PM
I think I will change all my vacuum lines for the silicone ones, what is the diameter and how much length will I need for the entire system?