PDA

View Full Version : Coolant temp light coming on



Kalsoj
07-19-2012, 02:36 PM
My coolant temperature light keeps flashing after about 10 mins of driving. I have checked the coolant levels and they are where they need to be everytime i check them. I am hoping someone might have an idea of what is going on.

My car is a 1996 (late 1996 early 1997)A4 quatrro, it has the 2.8l engine. please let me know if you have any ideas. Thanks

awdjunkies
07-19-2012, 02:44 PM
That's still a 12v correct? Either way it sounds like a CTS... Here are the instructions on R & R :

Coolant sensor on a 2.8 is on the rear of the engine on the passenger side below the air intake tube that runs across the firewall between the MAF and the throttle body. Its pointing straight up and down and is held in with a hairclip type retainer. Disconnect the electrical connector pull the clip out with a pair of needlenose pliers (goes towards the firewall) and pull the sensor straight up. Make sure the oring comes out with it as the new one comes with a new oring. Leave the cap on your surge tank and you won't loose more than a cup of coolant while the sender is out.

Hope this helps..


Unless, it could be a stuck T-stat, but you didn't mention any other symptoms or if the needle/temperature reading was also high..

wretchedwrench
07-19-2012, 02:49 PM
A bad thermostat could cause this along with a malfunctioning fan clutch or an inoperative electric coolong fan. Less common but possible is a bad water pump too. I've also seen plugged radiators too. A/C on or off? What does the temp guage read when your light is on? So there you have it just about any major componenent failure can cause this but at least you have ruled out the obvious by checking the coolant level!

Kalsoj
07-19-2012, 03:26 PM
No i dont have any temp surges, it is still at normal temperature the whole time. A/C does not work so that is not on.

prizmatik
07-20-2012, 12:11 AM
I would bet on the Coolant Temperature Sensor.