PDA

View Full Version : Smoothness



trev718
10-22-2011, 07:50 AM
hey A.Z'ers

I noticed my car isn't as smooth as it used to be after I added a 5mm spacer to the front
I must admit I havent gotten a wheel alignment but I wanted to know if this ever happen to anyone else??
I guess because it's not factory setting it feels like this?? Ball joints and upper and lower control arms are new in the front end... What can I do to bring the smoothness back?

215/45/17 front (5mm spacer) et25
235/40/17 rear (no spacer) et30
I bought the rims with these tires... Don't know if I need to balance them again

dbarbau89
10-22-2011, 10:32 AM
It happened after installing the spacer? Did you install using longer bolts? Check the inside of your wheels to see if any weights have come detached and fallen off. It happens some times.

Can you explain the lack of smoothness with more specifics?

trev718
10-22-2011, 10:52 AM
Longer wheel bolts have been install...I checked to see if any were loose and all was tight..... It's feels like every street I'm on is somewhat rough when I know it's not...
The tires still have a lot of thread left on it...or can it just be an alignment and balancing issue??

csosnowski
10-22-2011, 10:52 AM
are your spacers hubcentric? if they are off center of the hub even a little bit it can give a vibration.

trev718
10-22-2011, 11:49 AM
The spacers are made by h&r and they are not hubcentric but I do have hub rings for the rims...
There was vibration before But after I purchased the rings the vibration were gone...this only happen after I installed the
spacers...
5mm isn't much so why the rough ride?
Just checked my tire pressure and it's at 28psi
Bout to add some air to bump it up to 32 and see if that helps

trev718
10-27-2011, 02:21 PM
UPDATE:

My air pressure played a critical roll..I pumped all my tires back up to 32psi and it feels so much better than before...
I know air pressure plays a roll but I didn't expect 4 extra psi would do the trick..