PDA

View Full Version : 1996 Climate Control problems



vtraudt
02-01-2011, 07:34 AM
The climate control 'partially' works (fan, control unit, air vents, etc) but it does NOT get really warm.
The scan shows the following codes (below).
Where should I start with the troubleshooting. Someone told me NOT to jump at replacing the module yet.

Address 08: Auto HVAC Labels: 8L0-820-043-2D.lbl
Part No: 8L0 820 043 D
Component: A4 KLIMAVOLLAUTOMAT_D75
Coding: 04162
Shop #: WSC 06325
VCID: 29570979F97F

6 Faults Found:
00792 - A/C Pressure Switch (F129)
31-00 - Open or Short to Ground
00532 - Supply Voltage B+
07-00 - Signal too Low
01297 - Sensor for Vent Temperature; Footwell (G192)
30-00 - Open or Short to Plus
01296 - Sensor for Vent Temperature; Center (G191)
30-00 - Open or Short to Plus
01206 - Signal for Duration of Ignition Off Time
27-10 - Implausible Signal - Intermittent
01582 - Signal for Coolant Temperature
30-00 - Open or Short to Plus

Euromike
02-01-2011, 08:27 AM
All these open shorts make me think its an issue in module shorting out the whole incoming plug.

vtraudt
02-01-2011, 08:43 AM
Wires or ground connection bad?
How can I check? Get the center dash module out first?

Euromike
02-01-2011, 08:44 AM
im no electrical genious, but the first thing i would do is pull the module and check the connections for broken wires.

vtraudt
04-03-2011, 05:21 AM
I found a used module.
Do I just plug it in, or is 'recoding' needed? If so, what do I need to write down from the old module (VAGcom)?

vtraudt
04-10-2011, 07:16 AM
Decided (due to the number and what seems erratic appearance of codes) to get another used module for trail/error.

Installed module yesterday (unknown history, so I don't have final proof; could be just another bad HVAC module). When taking console apart, I noticed that there is a small fan, connecting to tube to the small center slot of the center console. In that slot is a temp sensor.

Below are the most recent codes before and after the switch. Some are the same, at least one is different (which could be from wrong install since it deals with the dash temp sensor):

The way I see it:
a) another bad module
b) module (or both) are ok, individual sensors issues
c) module (or both) are ok, sensors are ok, but wiring harness or connector or ground issue

Is it now time to attack each code individually?
Are those codes common (i.e. sensors fail)?
Aside from the 4 or so connectors in the back of the unit, and obviously the various sensors (with connector I assume), are there other elements/connectors in the path?
Where are the referenced (in the codes) sensors located?

New module 040911

Address 08: Auto HVAC Labels: 8L0-820-043-2D.lbl
Part No: 8L0 820 043 B
Component: A4 KLIMAVOLLAUTOMAT_D73
Coding: 04142
Shop #: WSC 06335
VCID: 27530F41EF6B

5 Faults Found:
00785 - Temp Sensor in Instrument Panel (G56)
30-00 - Open or Short to Plus
00792 - A/C Pressure Switch (F129)
31-00 - Open or Short to Ground
01297 - Sensor for Vent Temperature; Footwell (G192)
30-00 - Open or Short to Plus
01296 - Sensor for Vent Temperature; Center (G191)
30-00 - Open or Short to Plus
01206 - Signal for Duration of Ignition Off Time
27-10 - Implausible Signal - Intermittent


Old module 031111
************************************************** ****************************-
Address 08: Auto HVAC Labels: 8L0-820-043-2D.lbl
Part No: 8L0 820 043 D
Component: A4 KLIMAVOLLAUTOMAT_D75
Coding: 04162
Shop #: WSC 06325
VCID: 29570979F97F

6 Faults Found:
00779 - Outside Air Temp Sensor (G17)
30-10 - Open or Short to Plus - Intermittent
00792 - A/C Pressure Switch (F129)
31-00 - Open or Short to Ground
01297 - Sensor for Vent Temperature; Footwell (G192)
30-00 - Open or Short to Plus
01296 - Sensor for Vent Temperature; Center (G191)
30-00 - Open or Short to Plus
01206 - Signal for Duration of Ignition Off Time
27-10 - Implausible Signal - Intermittent
01582 - Signal for Coolant Temperature
30-00 - Open or Short to Plus