PDA

View Full Version : Burning Smell when Heat is on? B5



tjasielski
01-20-2011, 02:10 PM
Hey zine,


Whenever I turn my heat on, everything is normal for the first 5min, however after that I get a weird burning smell, almost like burning rubber. This will go away if I turn off the Climate Control then turn it back on after ~3min. However it will shortly return.

I also notice that when I turn my steering wheel to the right I can hear the fans whistle/chirp/whine.

Could this be due to the AC belt?

I live in Canada and I NEED proper Heat :)

Ps: I recently had my Precat o2 sensor replaced, however this also was occuring prior to that.

brettj20
01-20-2011, 02:12 PM
check your belts

_hmnib5
01-20-2011, 02:35 PM
could be burning oil,

not sure about the sound. Mine made
a real whiny sounds and it turned out to be the bearing going bad.

FNK
01-20-2011, 02:55 PM
I blame oil leak on/near exhaust/hot parts.

http://www.popularmechanics.com/cars/how-to/repair/2423551
http://www.popularmechanics.com/cm/popularmechanics/images/Ju/PMX0306Smells001-lg-de.jpg

tjasielski
01-20-2011, 03:27 PM
Valve Cover Gasket Perhaps?

cabby1
01-20-2011, 03:32 PM
Mine has a weird smell too. The dealer replaced the valve cover gasket and another small leak. But it didn't go away. The place where I have my oil changed wiped down real well an area on the motor, not exhaust. Helped for a bit but I can still smell it. So ???? Bit it doesn't seem to be burning off like it would on the exhaust and it is there when it warms up. Can smell it in the engine compartment. Not if I recirc the fresh air! Car is going crazy on me. Who knows...

tjasielski
01-20-2011, 03:46 PM
could be burning oil,

not sure about the sound. Mine made
a real whiny sounds and it turned out to be the bearing going bad.

Fan bearing?

FNK
01-20-2011, 05:10 PM
The burning smell on mine come the all of the transmission seals who are leaking. The oil doesn't burn, it just get hot and vapour enter the cabin when I use the fan too. As for the noise... video?

walky_talky20
01-20-2011, 06:57 PM
Most common cause for burning smell in the heat vents on the 2.8 is oil leaking onto the exhaust manifolds. Due to the angle of the head and the placement of the manifold the oil will slowly drip directly onto the hot manifold and it will burn off. This all happens in close proximity to the air intake for the HVAC system so you will get the smell through the vents. This is very common on the 2.8 30V, they all do it. Usually around 100k miles or so is when it starts.

The fix is to address the oil leaks:

- Valve cover gaskets
- Cam chain tensioner gaskets + half-moon plugs
- Cam plugs

Usually all of these are equally responsible, so just doing one or the other won't fix it.

tjasielski
01-21-2011, 09:13 PM
Thank you for your input! Ill be ordering my gaskets and will keep you posted!