PDA

View Full Version : Outside ambient temp display - up and down



ElSabio182
12-17-2010, 12:33 PM
Hey all,

Searched around, and I'm finding a lot of stuff about the Engine Coolant Temp sensor...I've installed those in the past, this is NOT related to the ECT. My coolent temperature dial on the dash is dead-center. My question is regarding the digital read-out that shows the temperature outside. It's been acting screwy in recent weeks, as its gotten cold. A few examples:

1)Driving home on the highway last week - after 4 hours, I noticed it was showing a temperature of -50 degrees. That temperature would fluctuate all the way back up to +30 over the course of an hour on the highway. I only noticed it when I turned on the interior heat.

2) This morning, on my way to work...when I started the car, it displayed -36 degrees (obviously wrong). Over the course of 2 minutes, it jumped back up to +23 (which was correct). Over the next couple minutes, it crept back down to negative territory, and bounced around a little until I got to the office. It only briefly "leveled out" at the correct temp.

So from the reading I have done...is the thermostat stuck open? Is this the same thermostat that gets replaced during the timing belt job? (because that has been done within the past 6 months). Am I doing any damage or putting uncessary stress on the engine by having this issue? Not sure if the engine/climate control performs based on that readout...

Thanks,
-G

Dallas09
12-17-2010, 12:46 PM
No its definitely not your thermostat. Sounds like your ambient air temperature sensor. It is located on the front lower grill on a little stand. Picture here of what it looks like, its the little thing with the wire running to it. http://www.audizine.com/forum/showthread.php/290575-10-Paypal-for-anyone-who-can-fix-this-Ambient-Air-Temp-problem

somebody5788
12-17-2010, 12:51 PM
No its definitely not your thermostat. Sounds like your ambient air temperature sensor. It is located on the front lower grill on a little stand. Picture here of what it looks like, its the little thing with the wire running to it. http://www.audizine.com/forum/showthread.php/290575-10-Paypal-for-anyone-who-can-fix-this-Ambient-Air-Temp-problem

x2

miggity02
12-17-2010, 01:09 PM
I've had the same problem. -50 outside when I live in northern California and rarely see +30s. Does the ambient temp sensor also affect the air conditioning ability of the defroster? At - anything I can't defrost but as the swing to the + temps happens it's like the compressor turns itself on. I've been getting weird readings for a while now but the inabiliy to defrost just started a few weeks ago. Sorry to thread jack but it sounded like we had a similar issue.

ElSabio182
12-17-2010, 01:56 PM
No its definitely not your thermostat. Sounds like your ambient air temperature sensor. It is located on the front lower grill on a little stand. Picture here of what it looks like, its the little thing with the wire running to it. http://www.audizine.com/forum/showthread.php/290575-10-Paypal-for-anyone-who-can-fix-this-Ambient-Air-Temp-problem

Niiiiice that sounds promising. Hadn't run across that thread, I'll get into it...thanks!