PDA

View Full Version : Keep blowing fuses, could use some help



Robb12
11-19-2010, 01:41 PM
So recently my car wouldnt start after filling up with gas, I got the code P1517 for the J271 relay. I recently just picked up a new relay and noticed the engine control unit fuse was blown so I replaced that as well. The car started, all was good..So on my way to work I make it a couple buildings away when BAM, car dies...same fuse was blown again. WTF mate...I tried sticking another 20A fuse and before I even put it in, it blew. I'm stranded at my office now with my car sitting in a lot down the street and dont know what to do. Any help would be appreciated.

Robb12
11-19-2010, 03:14 PM
Anybody? I've done some searching and found something could be shorting it out. I just dont understand why it'd blow after driving it for 10+ minutes. Could another blown fuse be the culprit, or maybe I got the wrong relay and should try putting the old one in?

ricekikr
11-19-2010, 05:29 PM
Not really to the point, but might help. Try the old relay first. If it still blows try a fuse that's 5 amps higher. This is to only let you drive home or to an electrician.

There's probably something wrong. A stripped wire that isn't always grounded (the 10minutes you were driving, then bump/vibration then its grounded) etc etc.

Robb12
11-19-2010, 05:50 PM
Well the fuse label says it'll take either a 20 or 30 amp fuse. I tried a 30 but it still blew, with the new relay however.

ricekikr
11-19-2010, 09:11 PM
Just reread your first post. I have a feeling your first relay was fine. The blown fuse probably caused your "no-start" and CEL problem. A short or overload of some sort is causing the blown fuse which in turn causes the no-start/CEL problem.

walky_talky20
11-19-2010, 10:21 PM
Robb12, it is fuse #29, right? I apologize for not discussing the fuse with you in your previous thread. I should have told you to check that first.

The only items on that circuit are the 4 coil packs and the ECU. I'm willing to be that either there is a short/frayed wire in the coil pack harness, OR you have a faulty coil pack that is pulling too much current. I would probably suggest checking the harness for obvious problem first, then (if that doesn't show anything) getting 1 replacement coil pack and swapping it until the problem goes away. That is probably the quickest way without cutting up the harness to measure current flow, etc.

As an extra check for the harness (besides visual) you could pull the fuse, unplug all the coil packs, unplug the ECU, and check for resistance between the coil pack power wires (red/green wire aka fuse 29 load) and chassis ground. If there is any continuity, you have a wiring fault. If there is none, make sure to shake the harness a bit while measuring to stir up the trouble. If it all checks out, you can move on to the coil packs. Good Luck.

Robb12
11-20-2010, 11:15 AM
Thanks for the help guys. I'll get on this today and let you know if I find anything. Snow is coming and I needz a car :S

Robb12
11-20-2010, 02:26 PM
Ok so a little update, I'm no longer blowing fuse 29 but it still wont start. Could the ground wire for the ignition coils be causing this? I've checked for frayed wiring and cant find anything. I'm still throwing a code for the J271 relay as well, even with the new one in.