PDA

View Full Version : Possible Clutch/Flywheel issue?



1.8T-Nick
09-28-2010, 11:53 AM
So I installed a xtd stage 3 6 puck clutch maybe 300 miles ago... now when i start the car it sounds like an extreme chatter. Not a normal chatter i have heard chattering before this is something extreme. Like something came loose inside the bellhousing. It replicates the noise on decel through any gear, it sounds between a rattle/gnarly vibrations/something spinning frealy/and a baddd chatter. I have been thinking that maybe a couple or more bolts broke off the flywheel? but I'm not real sure. the 6 puck had extremely harsh engagements that could shake the entire car quite aggresivley. I'm thinking it was one to many rough engagements and something broke inside. Any input would be appreciated, i know the xtd was a cheap clutch dont waste my time giving me shit. Just need help with the actual problem. thanks in advance

99blueb5
09-28-2010, 12:35 PM
So I installed a xtd stage 3 6 puck clutch maybe 300 miles ago... now when i start the car it sounds like an extreme chatter. Not a normal chatter i have heard chattering before this is something extreme. Like something came loose inside the bellhousing. It replicates the noise on decel through any gear, it sounds between a rattle/gnarly vibrations/something spinning frealy/and a baddd chatter. I have been thinking that maybe a couple or more bolts broke off the flywheel? but I'm not real sure. the 6 puck had extremely harsh engagements that could shake the entire car quite aggresivley. I'm thinking it was one to many rough engagements and something broke inside. Any input would be appreciated, i know the xtd was a cheap clutch dont waste my time giving me shit. Just need help with the actual problem. thanks in advance

could be something is loose, did you tighten all bolts to spec and in the right tightening order?, did you replace or re-use the bolts?

1.8T-Nick
09-28-2010, 12:42 PM
Thats what I was thinking. Yah all bolts were torqued to specs and the flywheel to crank bolts were replaced with the ones in the kit... however pressure plate to flywheel were not now that i think about it.. but i still used loc tite and torqued em right no diy's talked about replacing them so i didn't think it was neccessary.

99blueb5
09-28-2010, 12:56 PM
well if you get really bored one day you could take the tranny out and check everything out. did you install a new flywheel or reuse the old one?

1.8T-Nick
09-28-2010, 01:02 PM
Yah its looking like thats my only option. I installed a new 12lb one that came with the kit. It almost sounds like something is just free spinning inside but then at the same time it sounds like a knock sometimes. The initial start up of the engine sounds like the flywheel is just slapping away almost a knock sound. I almost think its just coming loose because the clutch still works perfectly fine.