PDA

View Full Version : Codes for injectors: 2-3-4 open circuit (detailed breakdown)



thenofjboy
06-09-2010, 01:58 PM
Im currently throwing codes for cyl. Injectors 2-3-4, as well as P0000 – but I’m not worried about that one.
17646 P1238 Cyl.2-Fuel Inj.Circ. Open Circuit .
17647 P1239 Cyl.3-Fuel Inj.Circ. Open Circ.
17648 P1240 Cyl.4-Fuel Inj.Circ. Open Circ.

Last Friday I went to install the following:
Painted VC + valve cover gasket
Painted IM + 034 spacer kit
New Throttle body gasket
Also cleaned the throttle body, catch can etc

All of that stuff was straight forward & ive taking the IM & VC off several times in the past. I also wanted to do a little wire tucking etc & I think this is where my problem is. So I went to start the car, which did start right away but started to turn over & gave it a lil gas and it was good. My RPM idle was good but my idle vacuum pressure was off. IIRC it was around 21hg previous but not it was around 11-12hg. When I went for a quick drive, 1st & 2nd gear were great – just as they were before but 3d gear was a joke. I couldn’t boost past p5si and it seemed a little boggy. I came home and checked everything out and then it would start. It would just crank but wouldn’t turn over. I tried to give it a lil gas but that didn’t do anything.

So Saturday I took off the IM to inspect the spacer kit & pretty much backtracked everything I did. Everything looked the same, double checked everything. When I 1st took off the IM, i wrote 1-2-3-4 on the injector plugs to remember which plug went with what injector. I also stripped the stock harness & re-wrapped each wire so I could tuck them under the fuel rail. I am human haha but im 99.9% sure I marked everything right before I removed anything. We checked each coil and its producing a spark & we checked the injectors and each one of them sprayed one at a time..cyl 1….cyl 2 etc…you can also smell the gas so it seemed it was not a fuel issue. The only thing that happened one of the time I was removing the fuel rail, it was stuck & I gave it a hard yank & it pulled out but the #3 injector was still in the IM. I cleaned off the injector, put the rubber seal back in its place & the clip was not bent at all so installed the injector back in the rail and moved on. This was the 1st time this has happened, usually the fuel rail + 4 injectors come out all together. I moved the ICM to near the under the IM just for the time being & I also extended the wire for the purge valve so I could hide it better. This was the ONLY wire I cut & I don’t think is my problem.

Saturday night the car started, similar to how it started the 1st time. I drove to the gas station to get a drink, 1st & 2nd gear were great but the same issue with 3rd. I came home & remove the line from my MBC to the wastegate bc I wanted to make sure my turbo was working, pulled out the driveway, bogged & died in the street. I put the hose back on but it would not turn over & we had to push the car back in the garage.

Since then I have been checking everything again, all the wires, adapters, bolts, clamps etc. I did find the green wire on my MAF was a little loose but I put that back together & used one of those shrinkable wire sleeves to seal it all up. Today I checked again & found the codes listed above. I checked the codes to see what they were & cleared them but the engine still wont turn over. I didn’t check thought to see if the codes came back but I will after work.

It seems strange that it started the 1st time and now I cant get it to turn over. My dad made the comment that maybe it was a fuel issue (this was previous to the codes I found) and I used up all the fuel in my fuel lines when I drove to the gas station & back, which was only a mile. 1st thing them im going to do is strip the injector wires that I wrapped to make sure all the wires are intact & the wires are intact under the rubber groomet on each injector. Once that is done, if I don’t find anything, I guess I have to break out the multimeter……..& go from there

- the car is a 98 KO4..

any advice/tips where else to look...start etc....
TIA guys [wrench]