PDA

View Full Version : GIAC chip only 10 PSI?



Glenns Audi
05-30-2010, 03:40 PM
So I was fortunate enough to get this car chipped already with a boost gauge.

I remember hitting 15 psi then settling down to 12. Now I'm only peaking at 11 then settling at 10 psi.

I don't have any leaks or a check engine light. When I went to Edge Motors they told me it might be my diverter valve, which is not stock from what I was told by the previous owner. I also know beacuse its louder than my cousins Audi also.

Any ideas guys? Thanks in advance.

danphines
05-30-2010, 03:49 PM
loud=boost leak probably
you could always check your diverter valve and see if it is stock or not. just because someone tells you something doesnt mean its true

JEmm
05-30-2010, 10:21 PM
loud=boost leak probably
you could always check your diverter valve and see if it is stock or not. just because someone tells you something doesnt mean its true

That. Check your dv and your n75, after that, check further for a leak. I hit 20 and taper to 15 consistently on giac.

turbo_bootin
05-31-2010, 07:55 AM
Boost leak test!

Glenns Audi
06-19-2010, 07:10 AM
Ok, I changed the stock (F version from what I saw) to an n75H race valve. I feel that the boost kicks in quicker and that I am hitting 12 PSI now rather than 10. I still think it should peak higher. I didnt see any noticable leaks when i was changing the n75 valve.

now the next thing to check is my DV. what exactly should I be looking for in regards of my car not boosting to its potential (GIAC Chip) with the DV?

Thanks guys!

danphines
06-19-2010, 12:34 PM
Ok, I changed the stock (F version from what I saw) to an n75H race valve. I feel that the boost kicks in quicker and that I am hitting 12 PSI now rather than 10. I still think it should peak higher. I didnt see any noticable leaks when i was changing the n75 valve.

now the next thing to check is my DV. what exactly should I be looking for in regards of my car not boosting to its potential (GIAC Chip) with the DV?

Thanks guys!


Look to see if its the stock dv. If it is then buy a new one. End.

Mister2
06-19-2010, 12:41 PM
The stock one is black plastic and is known to tear. I replaced mine with a Forge 007 DV (aluminum) and it made a world of difference. You would be fine with just replacing it with one off of a TT.

Glenns Audi
06-19-2010, 01:16 PM
not stock. looks aluminum to me. and its loud similar to a blowoff valve but not quite.

thenofjboy
06-19-2010, 04:29 PM
take it apart and see what color spring is in it & service it at the same time..The Forge DV's come with (4) diff color springs that are all for diff amt of PSI. you could always take a pic or find of pic of your DV & post it on here..

check all the vacuum lines & do a boost leak test

where in NJ are you?

Glenns Audi
06-20-2010, 11:47 AM
take it apart and see what color spring is in it & service it at the same time..The Forge DV's come with (4) diff color springs that are all for diff amt of PSI. you could always take a pic or find of pic of your DV & post it on here..

check all the vacuum lines & do a boost leak test

where in NJ are you?


Bergen County, Fair Lawn. I'll try to do when I have time.

10kredline
06-20-2010, 12:54 PM
Don't mean to jack your thread but how do you boost leak test? I know you can use a tennis ball technique, how is that?