PDA

View Full Version : Brake Light ?



np24
01-12-2010, 08:06 PM
The ABS and Brake light were illuminated on cluster. My abs module was dead. I sent it out to k0mpresd and he fixed it for me. He did a wonderful job, definitely worth the $50.
I put the module back in and checked for communication and codes. Communication was good and no codes, great.
The problem is that with the engine running, parking brake down, and brake reservoir above the min mark, the brake light stays illuminated on the dash. My car is a 98, I haven't had a chance to pull the passenger side tire to check for a brake pad wear sensor, but it shouldn't matter. I have the brake pad wear sensor turned off through vag-com.
What could be keeping the light on?
Could the switch on the parking brake handle be stuck closed?
I tried disconnecting the sensor on the master cylinder reservoir with no change.
Thanks

suju82
01-12-2010, 08:38 PM
I doubt it would be the switch stuck open since they are like fridge door light switches so more chance it would be stuck closed than open. Have you vagd the car?

np24
01-12-2010, 08:43 PM
I have the brake pad wear sensor turned off through vag-com.

Yes, I checked it.

mholme
01-12-2010, 08:45 PM
Is it just the light without the beeps?

np24
01-12-2010, 08:48 PM
Right, its just a red light with no beeping. The abs light is now off, since the repair.

mholme
01-12-2010, 08:51 PM
Sounds like it's on the parking brake circuit to me.

np24
02-24-2010, 06:04 PM
I finally got a chance to pull the center console and figure out what happened to the switch.
The little lock tab failed and someone tried to put a wire tye on it to hold it on. I snagged one from the junk yard, popped it in and good as new.
Its so nice to finally have all the lights off on the dash.