PDA

View Full Version : Spazzing turn signal :(



Seal 6
09-29-2009, 04:52 PM
i've noticed recently that my turn signal has decided to spaz out ever once in a while. it will blink irregularly, stop blinking all together, and then completely spaz out sometimes.
is that the stalk switch? i searched and found the thread on servicing the switch, but is that really the only cause? is that recommended to be self serviceable?

S4 BOOST
09-29-2009, 04:57 PM
Usually a problem like that is the Hazzard Switch..

-SHane

dcampana
09-29-2009, 05:02 PM
its the turn signal switch. had the same thing going on my car fro about 5 months, then it stopped blinking completely. bought at dealer for $38... good as new and takes 10 mins...

jamestown478
09-29-2009, 05:02 PM
^ he is correct. replace the hazard switch and the issue should go away. The switch is like 40 bucks from jhm I believe.

h4robkr123
09-29-2009, 05:49 PM
This should be what you were looking for: http://www.partsgeek.com/gbproducts/YN/B7464-OES-P3030.html?utm_source=google&utm_medium=ff&utm_term=01+2001+Audi+A4+Hazard+Flasher+Switch+OES +Genuine+Audi+Hazard+Flasher+Switch&utm_content=YN&utm_campaign=PartsGeek+Google+Base

spyder101
09-29-2009, 08:52 PM
I've replaced alot of hazzard switches for this concern BUT, I've also replaced a few stalks as well. I would say 65-70% is usually the hazzard switch at fault.

Seal 6
09-30-2009, 03:04 AM
is there a way to diagnose which one is the cause? the other thread with a similar problem had the signal blinking in the wrong direction and his problem was the stalk switch. My issue is that it will just stop blinking or blink irregularly on occasion and is getting worse. that sounds like the relay, right? are there any visual indications of failure on the part?
thanks for all the help, and sorry for more questions, lol. i just don't want to spend money on parts i don't need.

EDIT: Alright, so i've narrowed it down to the stalk switch since the hazards are working.

h4robkr123
09-30-2009, 11:34 AM
Although it doesn't pertain to this thread, I like your sig man.

99blueb5
09-30-2009, 12:57 PM
when the turn signal is on you can feel the hazard switch click when the light blinks, also check connections

4A Play
09-30-2009, 01:12 PM
http://www.audizine.com/forum/showthread.php?t=315395

dcampana
09-30-2009, 02:20 PM
well i would say the cheaper and easier route first (switch). if not, i have a spare stalk i will sell...

spyder101
10-01-2009, 05:47 PM
is there a way to diagnose which one is the cause? the other thread with a similar problem had the signal blinking in the wrong direction and his problem was the stalk switch. My issue is that it will just stop blinking or blink irregularly on occasion and is getting worse. that sounds like the relay, right? are there any visual indications of failure on the part?
thanks for all the help, and sorry for more questions, lol. i just don't want to spend money on parts i don't need.

EDIT: Alright, so i've narrowed it down to the stalk switch since the hazards are working.

NO! The hazzard function WILL still be operational, even if the switch itself is messed up. The hazzard switch is also the relay for the turnsignal switch. I would try the cheaper out of the two. If you feel uneasy about buying a new hazzard unit...then buy a know good used unit for less.

Seal 6
10-02-2009, 12:44 AM
alright cool. would the relay also be the cause of it not clicking and the indicator on the dash not blinking too? or would relay just be if the outside lights stopped.

i'm gunna see if i can pick up the part this weekend. or order it online since it looks like it's half the price, lol

dcampana
10-02-2009, 09:45 AM
i would bet that its the switch. i had the same thing on mine, and it was the switch. for the price and ease, start there, as they are notorious for going out.