PDA

View Full Version : unknown knocking please help



bigrobby
03-10-2009, 04:21 PM
2000 a4 1.8t 110k ATW

we think the car may be chipped by previous owner. either that or something is wrong making it a good bit more powerful than stock.

we found the vacuum line coming off the manifold had a hole in it so we replaced it. car runs very strong but there is a knocking...sounds like engine pinging.. coming from what sounds like under the car. this happens only under load....... in between 4 and 5k. at first we thought something loose in the drivetrain but i'm thinking it sounds exactly like knocking from the timing being too advanced.

no check engine light.
the only code was P1475 evap emissions leak detection pump.

the problem is consistent. between 4000 and 5000 under load...and loud.

any ideas?
thanks for the help

blmlozz
03-10-2009, 04:23 PM
already on the normal items? 7 series NGK's, 93 octane? There are a couple programs and features you can look for to see if the previous owner happened to leave it on a race gas file by chance, GIAC as a downloadable windows program selector, APR uses the cruise control stalk. It's also possible he had it custom tuned with limiwinks or similar, but it's best to start with the simple things listed first.

1NaudiA4
03-10-2009, 05:00 PM
If it really is knock your pretty much already screwed. If the knock is really that audible there has to be some serious detonation going on.

Check your coilpacks and inspect your spark plugs for signs of knock/lean condition.

bigrobby
03-10-2009, 05:01 PM
cleared the emissions code and knocking is gone. but i'm sure you guys know....things dont really just go away...i'm sure it'll be back.

yes new bkr7e's on new coil packs....93 octane fuel. no response from cruise control...plus i know its not APR....i have another apr tuned b5 and the mid range torque is really noticeable. the ECU is stock in appearance so it may have been flashed. it almost feels like a GIAC car by how it really picks up at around 4500 but if it is a GIAC car its still not running right.

the previous owner was actually according to my german audi guru mechanic "a crazy lady" who really tore the car up...she somehow destroyed the A/C control unit. point is it doesnt seem like the kind of owner who would chip it but who knows.

andyrew
03-10-2009, 05:03 PM
Is it more like a ting?

could be an exhaust leak, like a crack in your manifold or turbo..

Thats what I had. Under load, high rpm's. Went away when I went big turbo's

bigrobby
03-10-2009, 05:20 PM
no it's not a ticking like an exhaust leak. i've heard this sound many times in my years of cars and its only been two things. knocking (not rod bearing out type knocking) i mean pinging..as in timing too advanced. and yes i'm talking about detonation (not to be confused with pre-ignition). or some drivetrain issue. which it isnt because clearing the emissions code made it go away.

in case someone doesnt know what knocking or pinging sounds like.. ...it sounds like a terrible rattling and like things are going to just explode. and usually knock sensors, like the two on our engines, prevent it. thats why i'm confused

Stampy
03-10-2009, 05:29 PM
Did you check out your ecu? Sometimes you can get lucky and they will put a sticker on the ecu from the make of the chip, or the shop that did it.

1NaudiA4
03-10-2009, 05:35 PM
Do a third gear pull and log your knock sensors.


I highly doubt it is knock though. My guess would have to be something external.

I ruined my last motor due to unaudible knock with in 500 miles so I can't imagine how much longer your motor is going to last if you can hear it.

bigrobby
03-11-2009, 08:17 AM
no sticker. first thing i checked. it was not internal...i can definitely tell the difference between pinging and internal knocking due to something worn. and since i reset the engine codes it's completely gone now. went from very loud to gone. but things don't just magically go away...it'll be back i'm sure. i would love to log the knock but i just have a simple scanner/eraser vag-com. if it comes back i'll take it to someone who can log it.

flyromeo3
03-11-2009, 08:52 AM
^ EVAP Purge valve causing the knocking?

btw,..I just fixed my P1475 CEL.. I had to replace the Leak Detection Pump.

If you need help with it let me know. I kept updating one of my previous posts. also, I have a purge valve that I bought but didnt use it thinking that could of been the cause of my CEL.

Pm me or email Felipe_d2003@hotmail.com

flyromeo3
03-11-2009, 08:53 AM
Reason noise went away was that when you reset the CEL , it resets the purge valve too. so give it like 50 miles and it'll probably come back up

B5A4Kevin
03-11-2009, 09:04 AM
is it like a steady thump, thump, thump that seams to come from the rear of the car? because that is where the evap leak detection pump is. it tests the integrity of the fuel supply system and checks for evaporative fuel leaks by vacuum testing the entire system. if the fault comes back for the pump, i would suggest replacing it. also, you can test the n80 valve (near air filter) by checking for a clicking noise while at idle (electronically operational), and mechanically by blowing through it. you should only be able to blow through it when it is being commanded to click open and closed. if it leaks all the time, that could be the source of your fault.

flyromeo3
03-11-2009, 09:36 AM
is it like a steady thump, thump, thump that seams to come from the rear of the car? because that is where the evap leak detection pump is. it tests the integrity of the fuel supply system and checks for evaporative fuel leaks by vacuum testing the entire system. if the fault comes back for the pump, i would suggest replacing it. also, you can test the n80 valve (near air filter) by checking for a clicking noise while at idle (electronically operational), and mechanically by blowing through it. you should only be able to blow through it when it is being commanded to click open and closed. if it leaks all the time, that could be the source of your fault.


Even after replacing my pump I still couldnt hear it. Maybe you need a scope or something to hear it.

The purge valve ticks louder than the pump itself so hopefully thats what he is hearing.

bigrobby
03-12-2009, 10:51 AM
i'm sorry i actually don't know what the purge valve is. i've been working on AEB's forever ...is purge valve part of the air injections system.

and by the way this knock is loud and is definitely like engine pinging. the knock itself hasnt come back....but performance comes and goes. clearing codes helps. i feel like a rookie here asking...but this evap pump...what does it do and how would a problem with it affect performance? i hope this is something that came with ATW because if it's on my AEB somewhere i'll feel like a total moron...i've take that car completely apart....anyways..this pump....tell me more about it.

bigrobby
03-12-2009, 10:56 AM
is it like a steady thump, thump, thump that seams to come from the rear of the car? because that is where the evap leak detection pump is. it tests the integrity of the fuel supply system and checks for evaporative fuel leaks by vacuum testing the entire system. if the fault comes back for the pump, i would suggest replacing it. also, you can test the n80 valve (near air filter) by checking for a clicking noise while at idle (electronically operational), and mechanically by blowing through it. you should only be able to blow through it when it is being commanded to click open and closed. if it leaks all the time, that could be the source of your fault.

sorry i missed your post....thanks for the info. put it this way..the knocking was loud enough to hear very clearly fully throttle at 4500 with windows down goin 50ish. it had to be a timing induced knock. i'm thinking the vacuum leak i fixed again may have caused that code....now that i know what that pump is.

last time i scanned it, no CEL but i got a lean code. this car's got me all confused. i think i got a few things goin on.