PDA

View Full Version : O2 Sensor



seanj130
02-24-2009, 06:34 PM
Hey, i cant find a thread on this, but i was trying to trace the Upstream o2 sensor back to the original location, but as it goes through the wire grouping on the back of the motor i keep getting lost, im just trying to figure out where it starts, It is a 97 a4 1.8, please help, swapping it out tomorrow if i can figure this out!
Thanks,
Sean

zrowcool
02-24-2009, 06:36 PM
false firewall, right side under the coolant bottle. i think one is brown and the other is black IIRC

lawnferie
02-24-2009, 06:38 PM
yup. move coolant outta way and ull see them

seanj130
02-24-2009, 07:00 PM
so its a very quick install if i already have the sensor broken free?

njm23
02-24-2009, 07:25 PM
^^yes

seanj130
02-24-2009, 07:45 PM
sweet, and that would explain why when i tried to nonfoul my o2 sensor, it didnt work.. but now i can pass this bullshit NYS inspection tomorrow!!!

Seerlah
02-24-2009, 08:35 PM
^Not necessarily. If you have VAG com and you clear a CEL you have for the 02 sensor it will take a couple days for the ECU to pass readiness for emission components. FWIW, I drove around for maybe 2 months with expired inspection stickers till I finally placed on the non-fouler on my HFC (not bragging or trying to be pridefull, it is just something I had to do because I could not get the sensor off the bung).

ZacharyWS
02-24-2009, 08:53 PM
^Not necessarily. If you have VAG com and you clear a CEL you have for the 02 sensor it will take a couple days for the ECU to pass readiness for emission components. FWIW, I drove around for maybe 2 months with expired inspection stickers till I finally placed on the non-fouler on my HFC (not bragging or trying to be pridefull, it is just something I had to do because I could not get the sensor off the bung).


not to brag but: I just got pulled over last week for expried inspection. 10 day temp paper from july 4 2008 was still taped on the windshield. No ticket issued.