PDA

View Full Version : High Idle and P0507 code won't pass intpection



Volcano_black99
02-18-2009, 04:08 PM
Hello,

I just replaced the 02 sensor because my car didn't pass the inpection for emission test (engine light was on and code P1136 was found).
After the replacement, no more engine light neither code p1136 on the scanner.

But my car is still Idling at around 1200-1300 and the engine light just came back once it is connected to the scanner at the inspection.
So it didn't pass again for emission test.

The new code is p0507 which mean :
Idle Control System RPM: Higher than Expected

The mecanic that replaced the oxygen sensor cleaned the MAF, the fuel injector and the throttle body. And said that he has to investigate more to find out.

What do you think is the problem ?

Thanks in advance,

Cheers.

Poopie
02-18-2009, 04:27 PM
try to adapt the throttle body. if that doesn't work, you probably have a bad throttle body

Seerlah
02-18-2009, 04:28 PM
Ross-Tech says either Throttle Valve Control Module or wires to Throttle Valve Control Module. http://wiki.ross-tech.com/index.php/16891/P0507/001287

Volcano_black99
02-19-2009, 08:35 PM
Thanks for your reply.

D-Mar
02-26-2010, 05:44 PM
try to adapt the throttle body. if that doesn't work, you probably have a bad throttle body

I've never done one on a B7. I assuming its the same for all models. Remove battery contacts for a few minutes then reattach and turn key to accessories only?


Volcano, did you find out exactly what it was? I'm having the same problem and throwing the same code.