PDA

View Full Version : swapped injectors now car isnt starting...help



slideitsidewayz
01-17-2009, 01:52 PM
alright guys well yester night i swapped my stock injectors for some 440cc green tops, i test drove the car without sofeware to run the 440cc (i know thats not good but i was just testing it out.)

after installing the 440cc i followed the injector install instructions and turned the key a few times to fill the fuel rail...after a few turns of the key the car started right up.

today i was going to replace the 400cc with my stock injectors. i went to start the car up to pull it in the garage and the car didnt start. So i swapped the 440cc with the stock injectors in my driveway. i did the same exact process that i did when installing the 440cc. i turned the kep and filled the fuel rail and the car did not start when i cranked the key. ive attempted to crank the key to start the car a bunch of times and so far nothing has happened. the car sounds like its gonna start and gets some compression but then does not start.

can the car just be flooded from last night? how do i fix that? what else can be wrong? any help with be greatful thank you!

pipe7284
01-17-2009, 09:06 PM
first, put your stock injectors back in. Now does the motor turn over or it doesnt do anyhting at all with you turn the key? How is te battery charge? check that. also try tapping the starter a little while trying to turn it on.

pac1085
01-17-2009, 09:13 PM
sounds like you flooded it really bad.

pull the plugs and do a compresion test, i bet you have low compression from washed out rings and fouled out plugs.

if the compression is low pour oil in the cylinders until it comes back up, install new plugs and try to start car

slideitsidewayz
01-17-2009, 09:39 PM
thanks. i figured it was flooded. i just replace all the spark plugs about 2 weeks ago and the battery charge is good...its about 2 months old. it was around 2 degrees today and the cars in the driveway and i was stumped after swapping the stock injectors back in...so tomorrow ill check the plugs. yes the car is turning over when cranking the key, also i have unplugged the fuel pump fuse and cranked the key to drain the fuel but it still did not start.

i will check the plugs tomorrow. thanks guys