PDA

View Full Version : heavy clicking problem



kampfer
10-28-2008, 02:59 PM
I was hoping someone could help me with this,
when i accelerate both under load and not under
load i get some clicking noise coming from the engine
bay, i thought it was either the exhaust or the valves
sticking but im told the the valves auto adjust.
What could it be and how can i fix it. I tried addeding
new oil but still no joy i even added some thickening
agent to it.
help please.[:(]

kampfer
10-28-2008, 03:17 PM
No help? damn it...

kampfer
10-30-2008, 07:52 AM
well, i took it to genesis autosports i hope they can figure it out cuz i don't even know where to start.

TverRus69
10-30-2008, 08:03 AM
could be the timing belt click... check that out

biketsai
10-30-2008, 08:05 AM
Could be your CV axles

TverRus69
10-30-2008, 08:31 AM
well if it were CV related it would only click during turns wouldn't it? Also the sound wouldnt be from the engine bay. Where exactly in the engine bay is the clicking coming from?

kovalevandrew
10-30-2008, 08:40 AM
If it's coming from anywhere near your turbo... Have the wastegate and actuator checked out. Mine did the same thing.

akielb
10-30-2008, 08:47 AM
Drive shaft CV - Check the Trans mounts make sure they are not broken in half. - That's what mine was - but that sounded like it was coming from the trans, not the engine

kampfer
10-30-2008, 01:18 PM
Well guys looks like it might have been the turbo waste gate I'm picking up my car today so i will see. As for the sound well it sounds like its coming from the passenger side or maybe the fuel injectors I'm going to have these mechanics fix it I'm tired of trying to fix it. I just hope it was the turbo and not something else that way i dont have to pay for more. i just want the car to run nice again, enough with all these little noises and problems i'm getting. I still need a set of o2 sensors the MAF and maybe the N75 possibly even some new fuel injectors.
We will see.

akielb
10-30-2008, 03:16 PM
come back with an update once it's fixed, I sometimes hear that clicking I think when I let off the gas, nothing when accelerating

kampfer
10-30-2008, 04:47 PM
Well akielb i think i can help you actually. The clicking you have when you decelerate is for me at least my waste gate. I got into a bit of a crash late last year and cracked the waste gate some how and ever sence then i got less PSI and a loud clicking noise when i decelerate now as far as i understand its because the waste gate is not closing all the way but you can fix it one of two ways.
1. new turbo
2. new waste gate
3. maybe another solution I don't know
but yeah i hope that helps, i pick up the car today so i'll let you know tonight

kampfer
10-31-2008, 12:07 PM
YAY!!!!
Clicking went away, it turned out to be the broken waste gate.
hope that helps.