PDA

View Full Version : Sqweeeekk



Pureaudi
10-13-2004, 08:17 AM
oh man, my breaks squeek sooo much. its like a pulse. it dosent squeek in sertin parts of the rotation, its like its off balance or sumthing. they are new pads...grrr. whats wrong? any solutions?

thanks

EVIL-AUDI
10-13-2004, 08:24 AM
Perhaps they didn't bed correctly.

Pureaudi
10-13-2004, 08:47 AM
shhittt, what dose that mean? are my breaks ****ed? can it be fixed? is there a solution?

EVIL-AUDI
10-13-2004, 08:48 AM
When you first had them put in did you do the 60-0 stopping method to get them seated correctly?

Pureaudi
10-13-2004, 08:51 AM
i dont think so......i dont know what that is.....the mechanic never told me anything of that sort. he just said be easy on the breaks for a lil bit.

ogi520
10-13-2004, 08:53 AM
go check it out..don't they check them free? or..
it might be your roter..

EVIL-AUDI
10-13-2004, 08:54 AM
Normally when you get new brakes, especially BBK's, you'd take the car to 60MPH then bring it down to 0 a few times. Just to make sure the pads seat correctly with the rotor.

JMG
10-13-2004, 01:42 PM
I have the same problem with the EBCs. It used to squeak under ALL breaking ALL the time. The sqeaking was GREATLY reduced to maybe a few times every few days when I finaly did the 60-0 methos 2 days after installation.

Basically warm up your pads with some moderate braking. Then to 4 consecutive 60-0 hard stops without engauging the ABS. Drive for 10 minutes with moderate braking to let them cool a bit, then do 8 60-0 hard stops the same as before.

BUT I've also heard that EBC doesn't recommend this... they recommend moderate braking for up to 300 miles befoer oyu consider your pads bedded in. I didn't find this out until later, but my squealing was reduced with the 60-0 method anyway.

Pureaudi
10-13-2004, 04:24 PM
allright thanks guys ill try this out.

EVIL-AUDI
10-13-2004, 06:27 PM
Good luck.