PDA

View Full Version : sometimes slow sometomes fast



Michael18tq
05-29-2008, 05:36 PM
Hello all,

It seems there is something wrong with my car but I'm not sure what.
When the car is cold and first started (regardless of outside temp) it will boost quickly and respond well there is plenty of torque and it's good to drive.

However once the car warms up or on other random occasions it seems to be a little more doughy.
It's a stock a4 1.8t but has a large exhaust.
I've recently replaced the turbo due to a failing wastegate spring but that's it so far.

I've done a vag-com and did recieve a "Throttle Body j338 fault in basic setting error" - intermittent.
I've since cleared this code and done an adaption, it hasn't come back yet.
The car has a boost gauge on it and it will go to about .5 bar (around 7psi) quite quickly when it's fine but when it's feeling doughy it the gauge will move slowly up and it takes a bit of time to build up the boost.

However no matter how it drives it does rise to the appropriate level of boost and hold it so I'm not concerned about turbo operation or leaks.

My only guess is either the BPV or the n75 valve.
I've just picked up another BPV and I'll fit that on the weekend.
I'll also take the throttle apart and give it a good cleaning.

The questions I have are:
Could it be the N75 even though I have no error codes?
Could it be the MAF even though I have no error codes?

If it's either of these, how do I test it before I go replacing?

Looks like I'm getting a company car soon anyway so I don't really need to worry but I'd like to sell the car in perfect working order for the next guy.

audinutt
05-29-2008, 05:41 PM
replace the bpv if it hasnt been changed.
that or a defective n75.

-richard

Michael18tq
05-29-2008, 08:23 PM
ok, replacing the BPV this weekend (need to replace the belt tensioner anyway)
Such a bastard to get to down there...

audinutt
05-29-2008, 08:28 PM
It's easy if you jack it up mine took less than 10 mins.

-richard

audi1888t
05-29-2008, 08:29 PM
how long do bpv's work properly for i got the same pproblem and im using a dalhback one

t1demont1
05-29-2008, 09:00 PM
Depends which you use. the stocker will die at the sight of boost. If you use a forge or something similar, it should last a lifetime if maintained.

beejohn
05-30-2008, 12:21 AM
replace the bpv if it hasnt been changed.
that or a defective n75.

-richard

i don't think i've heard of someone legitimately having to replace their n75 yet....

could be the bpv