PDA

View Full Version : blinkers not working, hazards and parking lights do...



auditi
04-17-2008, 10:13 AM
as the title states, my blinkers stopped working, but the lights are not out, as they work when the hazards are on and the parking lights work. the cruise control still works too. also, the blinker stock does hold still hold its position during turns and releases when it is supposed to, the blinkers front and rear just aren't working.... what could this be?

t1demont1
04-17-2008, 11:54 AM
could be a fuse.

auditi
04-17-2008, 11:58 AM
i don't think it could be that cuz, as i forgot to mention above, when i hit the signal lever up or down, the appropriate signal on the dash (maybe on the outside too), lights up for one blink or less. its worth checking though....

diode
04-18-2008, 12:55 PM
hazard relay switch ftl.

auditi
04-18-2008, 12:57 PM
could it still be the hazard relay if the hazards are working, just not the turn signals?

Russell2686
04-18-2008, 01:04 PM
could it still be the hazard relay if the hazards are working, just not the turn signals?

yes thats what it is. it was the first thing i had to fix when i got my car haha

sciroccodriver
04-18-2008, 02:06 PM
Just bought my '01 a4 quattro a week ago... this is also one of the same problems I'm seeing... along with a bunch of much more expensive ones. (but the car was dirt cheap)
I assume this relay is in the dash near the hazard switch, right?

diode
04-18-2008, 02:13 PM
the hazard lights button is the relay switch, it's a rectangular box. Pop the whole thing out, it's not too tough.

djwimbo
04-18-2008, 11:10 PM
get a wiring diagram, throwing parts at it is just a waste of money. It could still be the turn signal switch(the lever assembly). Just b/c it resets after recentering the steering wheel doesn't mean the elctrical contacts are still functioning normally. There may also be wiring issue between point A and point B.

AudiRepair4Less
04-21-2008, 11:19 PM
The hazard switch is also the Relay, and It is Bad. I'm a audi Mechanic, and i See those things go out all the time.... First thing to check is turn your blinker on with your left hand, and tough the triangle button with you right hang. If the triangle button clicks or makes a noise Right after using the Switch most likely the switch. Very Rarely as is been the turn signal stock.... So, you dont think were just throwing parts at it, but from replacing tons of them. I would just replace it.

auditi
04-22-2008, 09:17 AM
thanks for the input guys, i'm gonna start with the relay, much cheaper than the stock, and i hadn't ever heard of one of those not working anyway... i had read about similar issues as mine stemming from the hazard relay, but couldn't find one where the hazards were still working... gonna pick up a new relay and go from there... [up]

sciroccodriver
05-02-2008, 08:27 AM
Hey auditi, as I mentioned, just got this A4 a couple weeks ago and I had the exact same issue as yours... ie hazards work, parking lights work, blinkers don't. I replaced the hazard switch for $31.00 ($38.00 retail) from the dealership and mine now work fine. HTH

auditi
05-02-2008, 08:37 AM
oh yeah, i just didn't update, replaced that switch last week or so, and yup, that was it, problem solved. at least it was a quick easy and cheap fix.... [up]