PDA

View Full Version : Weird boosting



andyrew
04-14-2008, 12:10 PM
So Last summer when I bought the car I was boosting around 20psi, Come winter and it slowly rolls down to 15psi. I first attributed it to my plugged cat from doing a seafoam treatment.. But now yesterday driving 200 miles I got on it a couple of times to pass people (So far im at 350miles on my tank w/ 1/4 tank left.. trying to get some good MPG readings before I install my stage 3 kit) and It runs right back up to 20psi! Keep in mind this is 5th gear @ 3krpms and my temp gauge says its 94 degrees outside.

Now Today Its 54 degrees outside in the morning and after its warmed up I do a quick boost in 3rd gear and its at 15psi.. Warmed up for lunch, about 70 outside and its at 17psi.

Can anyone explain this? This is a large amount of boost difference..

Current Setup:
k03
FMIC (Past summer no FMIC, no difference in boost due to no MBC)
GIAC file
Borla exhaust, 1st muffler delete
KNN filter w/ opened up airbox
Baileys DV

What are your thoughts? Freak of nature? Any logical explanation?

It doesnt really make much difference as I am installing my APR Stage 3 setup very shortly (Just got my 2 post lift installed in the garage). I just am really confused..

andyrew
04-14-2008, 09:38 PM
Wow no one?

20vpower
04-14-2008, 09:40 PM
boost leak maybe? have you tested it?

creechsa4
04-14-2008, 09:41 PM
yeah on the giac files, cooler weather gives you less boost readings, cause it's denser air. in 80+ degrees i used to jump up to like 20-22 psi on giac files, but still felt slower.

Rhinop21
04-14-2008, 10:51 PM
maybe a shot in the dark but how about colder air = denser air = not as much boost, but same performance due to lower iat's. its completly normal and im assuming you didnt feel a performance dif?