PDA

View Full Version : what the hell is this sound?



AHB900
03-12-2008, 08:49 PM
Hey guys i have a new sound to add to my list now i was wondering maybe someone might know what this sound is. it sounds like either a loose hubcap or something scraping on something when im braking. Anyideas?

devmaster
03-12-2008, 08:51 PM
its prob ur metal part of ur pads on your rotors.. that means get new ones

oneohone
03-12-2008, 08:56 PM
^x2

AHB900
03-12-2008, 09:40 PM
i just changed em lol :-\ i just got new rotors and new pads like 3 months ago.

ILoveT
03-12-2008, 09:43 PM
Wtf? You have hubcaps?

Stampy
03-12-2008, 11:25 PM
Wtf? You have hubcaps?

Bahahahahaha

djwimbo
03-12-2008, 11:53 PM
You sure you torqued down the caliper bolts and such? Seen it before where the "forward" bolt holding the caliper in came out and upon braking the caliper would lift up and hit the wheel.
Not a normal issue though.

Did you replace all four corners? of just the fronts? Possible that the rears are going out.

sorry, but that's a poor description of the issue. Take your wheels off, brake apart and inspect parts. Best way to figure anything out.

NakedDave8
03-13-2008, 11:58 AM
Hey guys i have a new sound to add to my list now i was wondering maybe someone might know what this sound is. it sounds like either a loose hubcap or something scraping on something when im braking. Anyideas?

Most likely the rear pads/rotors...I had the same thing happen to me less than a month ago with a metallic sound while I was braking. Looked at the rotors and they were grooved pretty bad. The solution....
http://i53.photobucket.com/albums/g79/trekfreerider8/IMG_0074.jpg
Cross drilled rotors and EBC red stuff ceramic pads to match the fronts.

AHB900
03-14-2008, 10:01 AM
uhh alright guys ill check that out. Uhh no i dont have hubcaps i said it SOUNDSSS like a hubcap slaping into the wheel. I have 18s

Ewok_Fetus
03-14-2008, 10:19 AM
Did you replace the anti-rattle spring?

AHB900
03-16-2008, 01:01 PM
no i didnt i used the original but i really dont think thats the problem because i have that problem on the left side of my car and it makes a completly different sound sounds like crickets at night pisses me off apparently my car is making noises from all 4 ends of the car :-\

Nebone
03-16-2008, 09:03 PM
I used to have a ticking noise in the rear when braking after I put on drilled rotors. I put normal ones soon after and it went away.

Tiluleshpingen
03-16-2008, 09:26 PM
Did you replace the anti-rattle spring?

lol[>_<]
its probably ur rears i had the same thing 6 months ago